Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

WebMail Lite Login Page

I've installed WebMail Live via softaculous. and configured it to run from this subdomain.
I want to have a login page with username only so that I dont have to type in my domain name each time I login.
Is there any tool/menu-option to do so or I have to do it manually by editing index.php or some other file.
Please inform how to do so.

Comments

  • edited January 23

    I tried modifying settings.xml file at email.sandeepan.info/htdocs/data/settings/settings.xml by making these changes.

    135 Login
    136
    137 DefaultOn
    138
    139 sandeepan.info
    140
    141 On

    It didn't solved my issue

  • I'm trying to do the following

    If my username is user, then I'll be entering user in the login page at email.sandeepan.info and @sandeepan.info will be appended to "user"

  • @Sandeepan said:
    I've installed WebMail Live via softaculous. and configured it to run from this subdomain.
    I want to have a login page with username only so that I dont have to type in my domain name each time I login.
    Is there any tool/menu-option to do so or I have to do it manually by editing index.php or some other file.
    Please inform how to do so.

    Hi,
    This would depends on the WebMail script you're using.
    A documentation of it might be helpfull.
    I personally do not recomend edditing anything without knowing what each part actually do.

  • @PlanetGamingGG , Thank you for replying.
    I'm using WebMail Lite available on softaculous
    And was following this documentation.

  • @Sandeepan said:
    @PlanetGamingGG , Thank you for replying.
    I'm using WebMail Lite available on softaculous
    And was following this documentation.

    Hi,
    I never used WebMail lite but i will try to use some common sense and reading some docs.

    But when you create a new account, do the script (WebMail Lite) require any username?

  • @Sandeepan said:
    @PlanetGamingGG , Thank you for replying.
    I'm using WebMail Lite available on softaculous
    And was following this documentation.

    Hey, I've founded it : https://github.com/afterlogic/webmail-lite/issues/44

  • @PlanetGamingGG said:

    @Sandeepan said:
    @PlanetGamingGG , Thank you for replying.
    I'm using WebMail Lite available on softaculous
    And was following this documentation.

    Hey, I've founded it : https://github.com/afterlogic/webmail-lite/issues/44

    Please have a look at my first post in this thread.
    I've configured it correctly but the settings.xml file is getting overwritten with default one each time I commit a change

  • @Sandeepan said:

    @PlanetGamingGG said:

    @Sandeepan said:
    @PlanetGamingGG , Thank you for replying.
    I'm using WebMail Lite available on softaculous
    And was following this documentation.

    Hey, I've founded it : https://github.com/afterlogic/webmail-lite/issues/44

    Please have a look at my first post in this thread.
    I've configured it correctly but the settings.xml file is getting overwritten with default one each time I commit a change

    Idk which line corresponds to which, can you post the part where you changed the config?

  • @Sandeepan said:
    I tried modifying settings.xml file at email.sandeepan.info/htdocs/data/settings/settings.xml by making these changes.

    135 Login
    136
    137 DefaultOn
    138
    139 sandeepan.info
    140
    141 On

    It didn't solved my issue

    @PlanetGamingGG, These are my settings from the beginning, or at least it is supposed to be.
    135 LoginFormType -> Login
    139 LoginAtDomainValue -> sandeepan.info
    141 UseLoginWithoutDomain -> On

    However, my settings.xml file is getting overwritten with default one I guess

  • @Sandeepan said:

    @Sandeepan said:
    I tried modifying settings.xml file at email.sandeepan.info/htdocs/data/settings/settings.xml by making these changes.

    135 Login
    136
    137 DefaultOn
    138
    139 sandeepan.info
    140
    141 On

    It didn't solved my issue

    @PlanetGamingGG, These are my settings from the beginning, or at least it is supposed to be.
    135 LoginFormType -> Login
    139 LoginAtDomainValue -> sandeepan.info
    141 UseLoginWithoutDomain -> On

    However, my settings.xml file is getting overwritten with default one I guess

    Hmm... If you're sure it's being overwritten, I can't do anything about it and only Admin can check it.

    But to test it, try to add a comment inside the xml file and save it, then see if the comment get overwritten or not

  • Configuration files should never be overwritten on their own. Or at least, not by the hosting system or by Softaculous.

    It's possible the software itself tries to fix the configuration files, but I don't know enough about AfterLogic's software to tell whether that's the case.

  • @Admin, can you verify from your end.
    This is where the file is.

  • @Admin
    I've found the issue (probably)

    There are two files in **htdocs\data\settings** directory
    1. settings.xml
    2. settings.xml.bak

    As the name suggest, settings.xml.bak file contains a backcup copy of all the configuration information and is continuously overwriting the settings.xml file.

    When I tried to change the settings.xml.bak file, it crashed the system.

    Is there any workaround ?

    I simply want a gmail-styled login screen where it will not ask me to type in @ sandeepan.info each time I login.

Sign In or Register to comment.