Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

The homepage I've created is not being displayed.

My index.php isn't loading by default instead I'm getting the "Let's Make Something Awesome" page.
Any help is appreciated as I'm new here.

Comments

  • edited February 13

    I had the same problem. I created a file called "index.html" and used it has redirect to index.php which solved the problem lol

  • edited February 13

    you need to define the starting/home page
    in .httaccess file inside of your htdocs folder

    # start here
    DirectoryIndex index.html 
    

    if starting page don't exist - make it

    if you use php then index.php
    if you use regular html then index.html
    you choose name....

    one can also do something like this

    DirectoryIndex index.html index.htm index.php

    server first go and check if exists index.html
    if not then check index.htm
    and if it does not exist, it will try to serve index.php

    means what you put first

  • @OxyDac said:
    you need to define the starting/home page
    in .httaccess file inside of your htdocs folder

    # start here
    DirectoryIndex index.html 
    

    if starting page don't exist - make it

    if you use php then index.php
    if you use regular html then index.html
    you choose name....

    one can also do something like this

    DirectoryIndex index.html index.htm index.php

    server first go and check if exists index.html
    if not then check index.htm
    and if it does not exist, it will try to serve index.php

    means what you put first

    Thanks for the information, never knew you could do this with .httaccess lol

  • @OxyDac said:
    you need to define the starting/home page
    in .httaccess file inside of your htdocs folder

    # start here
    DirectoryIndex index.html 
    

    if starting page don't exist - make it

    if you use php then index.php
    if you use regular html then index.html
    you choose name....

    one can also do something like this

    DirectoryIndex index.html index.htm index.php

    server first go and check if exists index.html
    if not then check index.htm
    and if it does not exist, it will try to serve index.php

    means what you put first

    @OxyDac said:
    you need to define the starting/home page
    in .httaccess file inside of your htdocs folder

    # start here
    DirectoryIndex index.html 
    

    if starting page don't exist - make it

    if you use php then index.php
    if you use regular html then index.html
    you choose name....

    one can also do something like this

    DirectoryIndex index.html index.htm index.php

    server first go and check if exists index.html
    if not then check index.htm
    and if it does not exist, it will try to serve index.php

    means what you put first

    The page now loads properly on my android but the problem still exists when I try opening it using chrome on my pc

  • Halfway there...

  • edited February 13

    @Lanturn Thanks for the information, never knew you could do this with .httaccess lol
    np & yw - the more problem you have the more you learn

    @SuryaXanden The page now loads properly on my android but the problem still exists when I try opening it using chrome on my pc

    you did not give us website address to check it out, but try simply
    clean chrome cache - go to your website address press F12, then CTRL + F5
    or in firefox CTRL + F12

  • @OxyDac said:
    @Lanturn Thanks for the information, never knew you could do this with .httaccess lol
    np & yw - the more problem you have the more you learn

    @SuryaXanden The page now loads properly on my android but the problem still exists when I try opening it using chrome on my pc

    you did not give us website address to check it out, but try simply
    clean chrome cache - go to your website address press F12, then CTRL + F5
    or in firefox CTRL + F12

    http://www.suryaxanden.epizy.com/
    Same problem persists on chrome incognito.

  • If I turn on developer tools, it works :D normal thing doesn't. I still am lost tho.

  • working here - This is an archive of PHP programs written by SuryaXanden
    btw. I wrote wrong - firefox = CTRL + F5

  • idk chrome hates me

  • edited February 13

    firefox ♥ you
    haahah valentines day

  • Resetting the site preference on chrome after modding the .htacess file fixed the issue.

This discussion has been closed.