Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

iframe 403 error

iframe work on localhost but if I upload in online host it's not work and say 403 Forbidden You don't have permission to access / on this server. How can I fix this?

Comments

  • edited March 22

    For starters, you could create a topic on this forum and post your URL in it so other people can have a look at it.

    Iframes run solely in the browser of the visitor, I don't think it's possible for a hosting provider to break it even if they wanted to. So being able to see how you're using iframes is important.

  • http://artmin-portfolio.cf/ . Heres my website. Check the Featured Products section.

  • Do you mean this section?

    Because it looks fine to me and I cannot find any iframes on that page.

  • Click this button

  • FYI: hotlinking is not possible on free hosting, so I can't see your image (you can see it because you opened the page already).

    The iframe issue itself seems to have very little relation to the iframe itself. If you open the included URL directly, you see the same issue. I also don't know how these embedded pages are supposed to work in your theme, so you may want to check the theme's documentation or the developer as well.

  • edited March 23

    Keep mouse on image and you can see search icon, click this iframe open.
    This is a my code (a href="http://artmin-portfolio.cf/components/quick-view?id=<?= $product['id']; ?>" class="quickview-link fancybox.iframe title12 round white">) for iframe.
    I type (http://artmin-portfolio.cf/components/quick-view?id=1) in url and it's open this page without error.

  • it's not an iframe just a fancybox

    line 419

    click on the image should lead to "more info"
    artmin-portfolio.cf/includes/blocks/quick-view?id=1

    but he has a lot of problems with
    include path =.: / usr / share / pear /

    see the error logs on his acc

  • Can I fix this?

    It's work on localhost.

  • @artminasyan said:
    Can I fix this?

    It's work on localhost.

    Who's to say whether you can fix this? But as far as I can tell, this is an issue with your website's code, not the hosting not working as intended. Why it works locally, I have no idea.

  • @artminasyan you're having iframe error with 403 right?
    May I get more details? so that I can help you
Sign In or Register to comment.