Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

css not working after applying https by cloudfare

css not working after applying https by cloudfare
you can see here
https://bloggersgroup.in/

Comments

  • and then purge cache from CF
    if it did not help let us know

  • edited June 9

    @Ashutosh4841 said:
    css not working after applying https by cloudfare
    you can see here
    https://bloggersgroup.in/

    Are you using Flexible SSL? I had the same issue as you and it solved when I selected full SSL.
    Flexible SSL breaks most WordPress websites, I am telling this from personal experience.
    Also, do what @OxyDac said if you haven't done already.

  • can you tell me steps becouse in infinity account thare is no seting for flixible ssl

  • @Ashutosh4841 said:
    css not working after applying https by cloudfare
    you can see here
    https://bloggersgroup.in/

    What the problem is you're serving insecure HyperText Transfer Protocols (HTTP) and Secure Sockets Layer (SSL) only serves for Hyper Text Transfer Protocol Secure (HTTPS).

    Meaning, your connection isn't 100% safe.
    So, simply replace your http://s with https://s in your code and it'll resolve all errors. In your Source Code you're showing sources starting with // which isn't transmitting a Protocol.

    So, just make the change or under your Cloudflare turn on Force HTTPS Rewrites. Which will still render the insecure issues until your code also meets HTTPS requirements.

    I've had the same issue, once I made the change it fixed everything.

    Also, you're probably going to have to Purge Everything under your Cloudflare Caching.

  • sory for thare is no seting in cpanel of cludfare for i need open a account in cloudfare than redarect the nameserver thare but after these it will not point for infinity

  • @Ashutosh4841 said:
    sory for thare is no seting in cpanel of cludfare for i need open a account in cloudfare than redarect the nameserver thare but after these it will not point for infinity

    Cloudflare does the magic and "tricks" the Name Servers so your website will remain online. When you register for a Cloudflare account your domain needs to have the current Name Servers ns1.epizy.com, ns2.epizy.com then you're going to set up your domain name through Cloudflare. When Cloudflare says to change your Name Servers you do it. You change them from ns1.epizy.com, ns2.epizy.com to what Cloudflare provides you then continue through the guided setup.

    Then under your Cloudflare Overview Dashboard you should see "Force HTTPS..." just enable all of them because you ALWAYS want to use HTTPS.

  • server ip address not found

  • i did that but it is not working

  • edited June 10

    Your site seems down (or is it just me?), you might want to check it out first.

    No matter if your site using HTTPS or not, when your browser cache isn't (force to) refresh/reload, the page may still look like the old one, though we've updated them to newer version of script. Try pressing Ctrl (or Cmd if using Mac) + F5 to force browser to get new cache of the site.

    In the other hand, flexible SSL may also affects your site as everyone stated above.
    Flexible SSL known to bring many side effects in here, commonly about infinite looping/redirection and broken page (which I don't really understand, but that's what happened).

    And according to Cloudflare, Flexible SSL secures the connection between client and Cloudflare, but not between Cloudflare and server (InfinityFree)

  • edited June 10

    @Ashutosh4841 said:
    https://bloggersgroup.in/ you can see that here

    We can't able to see your site because DNS_PROBE_FINISHED_NXDOMAIN kindly add an A records pointing towards IP of your site or change nameservers

  • @Ashutosh4841 said:
    server ip address not found

    Follow the steps as I’ve mentioned above. Your site is experiencing DNS routing issues. You need to assign the appropriate DNS records as I mentioned above. I can only help if I know what’s going on. May you post a screenshot of your DNS Redords and Name Servers for further assistance?

  • What the hell going on here.
    The problem, probably, is that he tryin to access unsecured http from secured https. Google chrome, for example, blocking that requests and CSS not loading.

    Tip: in tour pages, use not 'https://' or 'http://', use '//domain.com/file.css', it will pick up https if available/needed

  • @MrJunior said:
    What the hell going on here.
    The problem, probably, is that he tryin to access unsecured http from secured https. Google chrome, for example, blocking that requests and CSS not loading.

    Tip: in tour pages, use not 'https://' or 'http://', use '//domain.com/file.css', it will pick up https if available/needed

    When there no A record nor a CNAME record than how you can access a site?

  • You made his site offline lmao. He did like you said, some shit with nameservers and other stuff. I just said what he could do at the beginning.

  • @Ashutosh4841 said:
    sory for thare is no seting in cpanel of cludfare for i need open a account in cloudfare than redarect the nameserver thare but after these it will not point for infinity

    You never needed to change nameservers!
    First, as @MrJunior stated, your site is offline, so change your nameservers back to InfinityFree ones.
    Then, go to cpanel-CloudFlare, and enable CloudFlare for your domain. (Make sure you delete it first from CloudFlare before you re-create it).
    Go to the Crypto section, and select Full SSL, then also select Automatic HTTPS Rewrites and Always use HTTPS.

  • @ChrisPAR said:
    Then, go to cpanel-CloudFlare, and enable CloudFlare for your domain. (Make sure you delete it first from CloudFlare before you re-create it).
    Go to the Crypto section, and select Full SSL, then also select Automatic HTTPS Rewrites and Always use HTTPS.

    Exactly.

Sign In or Register to comment.