Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Getting 502 bad gateway error !!!

edited July 8 in Other Discussions

hi there,
I noticed that the frequency of 502 bad gateway has increased on a single page of my site ,though the issue is resolved by refreshing the page but still it is not a good thing ,for security reasons i cannot mention on which url i am getting this issue.

It initially occurred occasionally but now it happens always.

The webpage is an internal one at which users don't interact but i have to go there for statistical data.( i have an authentication system enabled there )

When i go there it shows the error then i refresh the page and it works fine then.

The error now comes most of the time.

Why is this happening and how can this be solved ??

Comments

  • Me too and now my website is down and it gives http error 500. I had the same problem when I was updating my plugins on my wordpress

  • @Rikhi55 said:
    hi there,
    I noticed that the frequency of 502 bad gateway has increased on a single page of my site ,though the issue is resolved by refreshing the page but still it is not a good thing ,for security reasons i cannot mention on which url i am getting this issue.

    It initially occurred occasionally but now it happens always.

    The webpage is an internal one at which users don't interact but i have to go there for statistical data.( i have an authentication system enabled there )

    When i go there it shows the error then i refresh the page and it works fine then.

    The error now comes most of the time.

    Why is this happening and how can this be solved ??

    The issue is described in this article: https://infinityfree.net/support/502-bad-gateway/ Does this answer your question?

    @tatianank said:
    Me too and now my website is down and it gives http error 500. I had the same problem when I was updating my plugins on my wordpress

    A HTTP error 500 and a 502 error are very different (hence the different codes) and have different causes. That error is described here: https://infinityfree.net/support/http-error-500/

    If that article doesn't answer your question, please create a new topic rather than reply to this. I'm not completely sure, but I think it's extremely unlikely that your issue and @Rikhi55 's issue have a common cause.

  • The issue is described in this article: https://infinityfree.net/support/502-bad-gateway/ Does this answer your question?

    well i guess i should just let it be there the way it is now, i experimented last night and observed that a fresh new ip experience this problem once i have accessed it , it works normally no matter how often i access it again i guess that after some session it happens again....its kinda weird but lets see how long this issue continues,i don't mind much as it is an internal page.... btw re configuring and checking out codes with such a small error will be nerve-wrecking task so its better leave it than to making another mistake and i think cloudflare might be a potential reason but re configuring the website again is not motivating at all...thanks for replying....

    If that article doesn't answer your question, please create a new topic rather than reply to this. I'm not completely sure, but I think it's extremely unlikely that your issue and @Rikhi55 's issue have a common cause.

    true, @tatianank 500 error is in most cases due to errors in coding or scripts,it will be highly advised to check your code file(php,js etc.)/script again as it can be the only solution to your problem.

Sign In or Register to comment.