Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

my website went down after changing nameserver

I change my name server to cloudflare's to get my SSL certificate and after that my site went down, why is that ?

Comments

  • @DavidFco said:
    I change my name server to cloudflare's to get my SSL certificate and after that my site went down, why is that ?

    Hi,
    What's the error?
    What's your domain?

  • You should enable Cloudflare by VistaPanel, but not enable it by yourself.

  • He don't have to enable cloudflare in vPanel if he's changing nameservers to CF's ones.

  • edited September 17

    @DavidFco said:
    after that my site went down, why is that ?

    down is hard word
    It's probably all right with your site but you're experiencing this
    https://infinityfree.net/support/why-doesnt-my-domain-work/

  • @UnknownLolz said:

    @DavidFco said:
    I change my name server to cloudflare's to get my SSL certificate and after that my site went down, why is that ?

    Hi,
    What's the error?
    What's your domain?

    mobilegeeks.ga

  • @yezhiyi said:
    You should enable Cloudflare by VistaPanel, but not enable it by yourself.

    Pardon my level of ignorance, but I’m new to this, I you do not recommend to do it on my own, how do i go about that then?

  • @UnknownLolz said:

    @DavidFco said:
    I change my name server to cloudflare's to get my SSL certificate and after that my site went down, why is that ?

    Hi,
    What's the error?
    What's your domain?

    Now I made some changes recomended by CloudFlare and now I'm getting "Error 521" stating that "Error 521 occurs because the origin web server refuses a connection from Cloudflare. More specifically, Cloudflare tried to connect to your origin server on port 80 or 443 but received a connection refused error."

    Help please !

  • @DavidFco said:

    @UnknownLolz said:

    @DavidFco said:
    I change my name server to cloudflare's to get my SSL certificate and after that my site went down, why is that ?

    Hi,
    What's the error?
    What's your domain?

    Now I made some changes recomended by CloudFlare and now I'm getting "Error 521" stating that "Error 521 occurs because the origin web server refuses a connection from Cloudflare. More specifically, Cloudflare tried to connect to your origin server on port 80 or 443 but received a connection refused error."

    Help please !

    Hi,
    Your site works here but in a bad state.

  • @UnknownLolz said:

    @DavidFco said:

    @UnknownLolz said:

    @DavidFco said:
    I change my name server to cloudflare's to get my SSL certificate and after that my site went down, why is that ?

    Hi,
    What's the error?
    What's your domain?

    Now I made some changes recomended by CloudFlare and now I'm getting "Error 521" stating that "Error 521 occurs because the origin web server refuses a connection from Cloudflare. More specifically, Cloudflare tried to connect to your origin server on port 80 or 443 but received a connection refused error."

    Help please !

    Hi,
    Your site works here but in a bad state.

    Yes, because the server is not actually allowing cloudflare's I also switch A to CNAME because based on the info I read, the actual IP address that I found is not the website's IP address but the FTP's server. So I had to change to CNAME using @ on the name field and my "Main Domain" as the value, which I've done and nothing changes :/

  • I found a fix, for anybody using Infinityfree hosting, you need to
    1- change servername to cloudflare
    2- set a CNAME with “@” as name and your “Main Domain” as the value (Don’t use the IP address since it’s the FTP’s server IP address and not the actual website’s)
    3- set another CNAME “WWW” and “@” as value
    4- Go to Crypto area, set Full SSL and enable “Automatic HTTPS Rewrites”

    That fixed my issue !

  • @DavidFco said:
    2- set a CNAME with “@” as name and your “Main Domain” as the value (Don’t use the IP address since it’s the FTP’s server IP address and not the actual website’s)

    I really don't understand why people still believe that the FTP server IP address is their website IP address. As far as I know, this IP address isn't supposed to be as a recommended setting anywhere, and in the cases where it is, it's clearly labelled as an FTP server IP, not the website IP or account IP or whatever.

    Also, this is process is already documented here: https://infinityfree.net/support/find-your-ip/

    @DavidFco said:
    4- Go to Crypto area, set Full SSL and enable “Automatic HTTPS Rewrites”

    A well configured website doesn't need automatic rewrites.

  • So how should I configure it ?

  • edited September 19

    @DavidFco said:
    So how should I configure it ?

    That depends on your website. Check the documentation for your software to learn how to change the URL. Some software (like WordPress) offer it in the admin area. Others provide the option through a configuration file. A few don't require any configuration at all and work just like that.

    But automatic rewrites are a crutch which should only be used as a last resort, not as a default option.

Sign In or Register to comment.