Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Website keeps reverting to the self-signed SSL certificate

Hello, everybody.
I successfully set up my SSL certificate, which I purchased from Comodo. Last night everything was working fine and I was able to get a green lock when I visited my website. Today, I woke up and found that the website has reverted back to the default self-signed SSL certificate. I checked on my cPanel and the certificate I purchased is still there, the configuration has not been changed. Now, everyone who tries to visit my website is getting the error "Your connection is not private (NET::ERR_CERT_AUTHORITY_INVALID.)"
Can you, please, help me with that?

This is my certificate:

-----BEGIN CERTIFICATE-----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-----END CERTIFICATE-----

Thanks in advance.

Comments

  • @tpms16 said:
    Hello, everybody.
    I successfully set up my SSL certificate, which I purchased from Comodo. Last night everything was working fine and I was able to get a green lock when I visited my website. Today, I woke up and found that the website has reverted back to the default self-signed SSL certificate. I checked on my cPanel and the certificate I purchased is still there, the configuration has not been changed. Now, everyone who tries to visit my website is getting the error "Your connection is not private (NET::ERR_CERT_AUTHORITY_INVALID.)"
    Can you, please, help me with that?

    This is my certificate:

    -----BEGIN CERTIFICATE-----
    MIIGVTCCBT2gAwIBAgIQTVqcWIzq0IV53M1DhYma9jANBgkqhkiG9w0BAQsFADCB
    kDELMAkGA1UEBhMCR0IxGzAZBgNVBAgTEkdyZWF0ZXIgTWFuY2hlc3RlcjEQMA4G
    A1UEBxMHU2FsZm9yZDEaMBgGA1UEChMRQ09NT0RPIENBIExpbWl0ZWQxNjA0BgNV
    BAMTLUNPTU9ETyBSU0EgRG9tYWluIFZhbGlkYXRpb24gU2VjdXJlIFNlcnZlciBD
    QTAeFw0xODEwMDYwMDAwMDBaFw0xOTEwMDYyMzU5NTlaMFIxITAfBgNVBAsTGERv
    bWFpbiBDb250cm9sIFZhbGlkYXRlZDEUMBIGA1UECxMLUG9zaXRpdmVTU0wxFzAV
    BgNVBAMTDnRlcGFtZXMub25saW5lMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIB
    CgKCAQEAs84j7I12+yXMLxnyphIHjkA7JCyaUOChsRrrm+cOhh7onIZ6cxiYKDN/
    ZfAwzOskedqAK3FtGlp3SrsRIdbWqIsEZQJZ2zGSmLLTGekVRD6JuHUYqAfaO6yF
    Z2tvBlUQFUuHttH1Fml8sEcSkm2ZHu3m9WZ+h5VdlTF1u7r+F/T61/sXkUFOqMXv
    ioNrScVAzWrCBKdi+nwJABMpv0pbl8MucsZAcpJCFKvhcsRH3t34GnIp/HBJCFTi
    Rvi3In/NsJUue5sByKErMY3UF9gvJSoM1UHSSd7DtTbaxNGKgp4PecDhNvwKAY+w
    G2IsAdDqTazU32jBDq6rgimLnq11fwIDAQABo4IC5jCCAuIwHwYDVR0jBBgwFoAU
    kK9qOpRaC9iQ6hJWc99DtDoo2ucwHQYDVR0OBBYEFOunBlJGucnHS5sKKNTdoq1v
    OEvFMA4GA1UdDwEB/wQEAwIFoDAMBgNVHRMBAf8EAjAAMB0GA1UdJQQWMBQGCCsG
    AQUFBwMBBggrBgEFBQcDAjBPBgNVHSAESDBGMDoGCysGAQQBsjEBAgIHMCswKQYI
    KwYBBQUHAgEWHWh0dHBzOi8vc2VjdXJlLmNvbW9kby5jb20vQ1BTMAgGBmeBDAEC
    ATBUBgNVHR8ETTBLMEmgR6BFhkNodHRwOi8vY3JsLmNvbW9kb2NhLmNvbS9DT01P
    RE9SU0FEb21haW5WYWxpZGF0aW9uU2VjdXJlU2VydmVyQ0EuY3JsMIGFBggrBgEF
    BQcBAQR5MHcwTwYIKwYBBQUHMAKGQ2h0dHA6Ly9jcnQuY29tb2RvY2EuY29tL0NP
    TU9ET1JTQURvbWFpblZhbGlkYXRpb25TZWN1cmVTZXJ2ZXJDQS5jcnQwJAYIKwYB
    BQUHMAGGGGh0dHA6Ly9vY3NwLmNvbW9kb2NhLmNvbTAtBgNVHREEJjAkgg50ZXBh
    bWVzLm9ubGluZYISd3d3LnRlcGFtZXMub25saW5lMIIBAwYKKwYBBAHWeQIEAgSB
    9ASB8QDvAHUA7ku9t3XOYLrhQmkfq+GeZqMPfl+wctiDAMR7iXqo/csAAAFmRy2r
    egAABAMARjBEAiB2bkuQN+0x0d+Dw//JaWnhROb7BOCVuzy9lMdkNwArwQIgPaAw
    cJOuX/3BLXn0U7sCCFEUn8mugTAfMeGdl6uSICIAdgB0ftqDMa0zEJEhnM4lT0Jw
    wr/9XkIgCMY3NXnmEHvMVgAAAWZHLavHAAAEAwBHMEUCIEjhDpVKGGqBiRs85Aot
    OpfPVGNY46ZWZPURnEPx2AW3AiEAm+WEggHsbnxiErMNBuGRu2NxG9HMXv9yk0iN
    FCNV1ggwDQYJKoZIhvcNAQELBQADggEBAG+L9l2gllFZg7Vd3ayI4bImUj+kSamT
    FVBp0aB78/yCDgd6jHUeCLLhkgCSEeSA32adqNPEhHdLjOfGmAHZKoPK/2bkTz7Y
    sdpKMVapEnMNtQ9Ad0EHf8lwfSqlBILB4qvbznn1B5wcnEBxmmjEF7w8BdLYW593
    zyW66mpXuGtEhD3HJP4M/sXFINnCQqUR9i7vcByXoGy9nSpv+KNsiRlEHHevo0MQ
    mVQ8b2NFvq0/p4iK9oj/jpZgUFIhDiy5A4f+uz3A+VRpo584HRUq3+kghJZhooub
    0EPeOv/l+6Ra8/h+qk/dQ2S9vGBJ7E6vNRy7sN16dBz423Hitiq//RU=
    -----END CERTIFICATE-----

    Thanks in advance.

    Did you clear your browser's and DNS cache?

    Also, did you try visiting your website with a VPN or asking a friend to visit it? Otherwise, how can you be sure that everyone sees the default?

    If none of these works, give us your URL please.

  • Hello, ChrisPAR. Thank you for replying.
    Yes, I tried loading the website using many different devices, used different Wi-Fi and 4G networks, tried Opera Mini, and asked a friend to try loading it, but I still get the invalid certificate error.
    My website is tepames.online.

  • By the way, I also tried this SSL checker: https://sslshopper.com/ssl-checker.html?hostname=tepames.online.
    Last night it showed my certificate, but today it's showing the dummy self-signed certificate.

  • @ChrisPAR said:
    If none of these works, give us your URL please.

    None of the methods you mentioned worked. :(
    Any other way I can try to fix it?

  • @tpms16 said:

    @ChrisPAR said:
    If none of these works, give us your URL please.

    None of the methods you mentioned worked. :(
    Any other way I can try to fix it?

    That's just weird.

    Did you try to click on "Upload Certificate" again? Have you also uploaded your private key?

    Also, if this doesn't work again, maybe @Admin should look onto your account and check it.

  • @ChrisPAR said:

    @tpms16 said:

    @ChrisPAR said:
    If none of these works, give us your URL please.

    None of the methods you mentioned worked. :(
    Any other way I can try to fix it?

    That's just weird.

    Did you try to click on "Upload Certificate" again? Have you also uploaded your private key?

    Also, if this doesn't work again, maybe @Admin should look onto your account and check it.

    I know it's weird, it just stopped working all of the sudden. And, yes, I uploaded the private key and certificate multiple times to see if that would fix it, but to no avail. It's been like that for almost 12 hours.
    I would greatly appreciate it if somebody can look into my account to see what's causing the default certificate to replace my own certificate.
    Thanks again.

  • @tpms16 said:

    @ChrisPAR said:

    @tpms16 said:

    @ChrisPAR said:
    If none of these works, give us your URL please.

    None of the methods you mentioned worked. :(
    Any other way I can try to fix it?

    That's just weird.

    Did you try to click on "Upload Certificate" again? Have you also uploaded your private key?

    Also, if this doesn't work again, maybe @Admin should look onto your account and check it.

    I know it's weird, it just stopped working all of the sudden. And, yes, I uploaded the private key and certificate multiple times to see if that would fix it, but to no avail. It's been like that for almost 12 hours.
    I would greatly appreciate it if somebody can look into my account to see what's causing the default certificate to replace my own certificate.
    Thanks again.

    Browsers cache SSL certificates. So after installing a new SSL certificate, one browser/device may still remember and use the old SSL certificate but other devices/browsers will use the new one and not show any errors. Usually, opening the website in Private Browsing mode is enough to circumvent the cache.

    As far as I can tell, there is nothing wrong with your SSL certificate or your hosting account. Just have patience and all devices/browsers will pick up the new certificate and be able to open your website without errors.

  • edited October 7

    @tpms16

    I was able to visit your website with an SSL certificate, however it seems like the Let's Encrypt certificate you have is issued for http://ssl-not-enabled.com/ and not for your domain.

    It might be worth checking out.

    If you want a free SSL you can either use CloudFlare or follow this guide here:
    https://forum.infinityfree.net/discussion/4766/how-to-get-free-lets-encrypt-ssl-for-your-website

Sign In or Register to comment.