404 with txt file, no problem with html or php


it’s the first time i got problem with an hoster downloading a txt file.
I’ve tried with htaccess, curl, etc still get a nice 404 or 302 error (with curl).

the txt file is located on th htdocs root.

Is there any config i missed.

Thx for you help.

what’s your site url And from where are you trying to access your text file?

1 Like

my site is protected by htpass as i don’t want to make it public.
but to make it short : mysite.rf.gd/mytext.txt with hello world as content.

Using curl with options no problem to get the user/pass working.
But once it try to read the file (chmod 644) it return a 404 error.

mytext.txt doesn’t exists at all. Note: This host is Case sensitive. which means you’ve to rename your txt file to lower cases!

Edit: digged it up. You’ve given me fake url. However make sure that file exists!


It was just random name a give a sample, i’m aware of linux case sensitive.

It’s really the first time in 23 years of dev i got this case…

yeah :slight_smile:

and i forgot scandir see the file

I tried to go to that URL and got “Warning! This website contains malware. Visiting this website may harm your computer!” Yikes.

I moved php and txt files on another free hoster and no problem. I think it’s the www config. About malware the index2.html created during the setup process is detected by antivirus.
I guess a script included in the page but i deleted the page and didn’t checked the code.

The only scripts included in the default page are stuff like Bootstrap and jQuery, all loaded from major CDNs like Cloudflare. If your antivirus says the default page is harmful, then your antivirus is wrong.

1 Like

I noticed the page are with ?z parameter, also blocked by malwarebytes. Too many redirections.
I tried at work and in family too see if it wasn’t on my side but same error.

I also have a ifastnet account and no problem.

I found the solution on the free plan, i just add url/myfile.zip?i=1, using i=1 make it works without error 404

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.