After setting up my SSL , HomePage is Secure , the rest of pages/post redirect to 404 Page Not Found

Hi

I have setup SSL to my site but noticed that homepage is secured ok but if i click any link on menu i got 404 Page Not Found. Website is www.getonlinecourse.com

Any idea what is missing?

Thanks

@mur2cc said:

Hi

I have setup SSL to my site but noticed that homepage is secured ok but if i click any link on menu i got 404 Page Not Found. Website is www.getonlinecourse.com

Any idea what is missing?

Thanks

Hi,
Try:
Go to WP Admin Area --> Permalinks --> Save Changes.

@mur2cc
WOW, you are sharing Paid Courses for Free, or crime in simple way, this is not right place to host it

Hi

I fixed the issue adding the following to .htaccess file :

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

@Ranakhas said:

@mur2cc
WOW, you are sharing Paid Courses for Free, or crime in simple way, this is not right place to host it

Are you sure?
I visited his site and click some of the “Get course” button and it redirected me to Udemy.
Therefore in my conclusion he ain’t sharing paid courses for free.

@mur2cc
Are you really sharing paid courses for free (not literally mean you shared courses or promote a course)?

It looks like a Udemy affiliate site. I don’t see anything harmful in that.

But the site is working fine from here.

@Admin said:
It looks like a Udemy affiliate site. I don’t see anything harmful in that.

But the site is working fine from here.

When I visit I though It was some of site which I hates the most shares one of our courses for free at that moment I try open a post but gives error 404 but now it is working fine.

@Admin and @mur2cc I want to say Sorry for misleading you and misunderstanding I 'm sure you guys will accept my apologizes, I don’t want to mislead anybody and spam this forum or any other because I hate that too!