Cannot Activate Yoast plugin


When i install Yoast plugin and activate, below message will appear in my Dashboard

The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

and when I visit my website it will show

The site is experiencing technical difficulties.

Also below message will appear in Yoast plugin dashboard

The first true all-in-one SEO solution for WordPress, including on-page content analysis, XML sitemaps and much more.

Version 11.6 | By Team Yoast | View details
This plugin failed to load properly and is paused during recovery mode.

An error of type E_ERROR was caused in line 19 of the file /home/vol11_2/ Error message: Uncaught Error: Class ‘WPSEO_Frontend’ not found in /home/vol11_2/ Stack trace: #0 /home/vol11_2/ initialize_wpseo_front(”) #1 /home/vol11_2/ WP_Hook->apply_filters(NULL, Array) #2 /home/vol11_2/ WP_Hook->do_action(Array) #3 /home/vol11_2/ do_action(‘init’) #4 /home/vol11_2/ require_once(‘/home/vol11_2/e…’) #5 /home/vol11_2/ require_once(‘/home/vol11_2/e…’) #6 /home/vol11_2/ require(‘/home/vol11_2/e…’) #7 {main} thrown

I am experiencing this for a month already.

Try force uninstalling the plugin by going with a FTP client on htdocs/wp-content/plugins/ and deleting the wordpress-seo folder, then download the plugin from here, extract the zip file on your computer and upload the new folder on htdocs/wp-content/plugins/ with the same FTP client as before.

I tried that method already but still experiencing the same error.

you can check our conversation with other infinity user here:

Maybe your WordPress is a bit corrupt. Try using this guide to reinstall a healthy WordPress.
And the conversations on the WordPress support forum maybe aren’t of InfinityFree users.

Thank you!

I will check and get back for updates.

1 Like



1 week ago

After a lot of testing, it seems that the root cause is the hosting itself…

It seems that you are using infinity hosting right?, I’m using Byethost that is almost the same thing, but only to test I tried also infinity and I get the same result…

Finally I tried with another host and the problem is gone.

1 Like

Yes, InfinityFree uses iFastNet’s infrastructure and Byethost is iFastNet’s own free hosting brand. The services are very similar, and it makes sense that the same issue affects accounts on either service.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.