Can't change error pages

My website URL is: http://pocket-inc.ml

What I’m seeing is: when I try to change error pages from the CPanel I get a 403 forbidden page with “You don’t have permission to access /panel/indexpl.php on this server.”.

I’m using this software: Microsoft Edge Insider (Chromium)

Additional information: It was doing that since more than a month.

Would you mind if I try to change it? Which error page would you like to change and what is the URL you would like to change it to?

2 Likes

I’d like the error page for them to be http://pocket-inc.ml/error.php?code={error code}
{error code} is like 404 or 403 depending on error.

like for 404,/error.php?code=404

for 403, /error.php?code=403

If I had to guess, I would say the problem is caused by bad validation rules in the control panel. Can you please try changing the error pages to just http://pocket-inc.ml/error.php, so without the code argument? If that does work, you can also go into the .htaccess file yourself and add extra parameter there.

1 Like

That didn’t fix it…

Then try to create a .htaccess file on your domain’s htdocs folder with the following contents:

ErrorDocument 403 /error.php?code=403
ErrorDocument 404 /error.php?code=404
1 Like

That works, but I’m talking about the Panel’s.

I just tried to update your error pages, but I didn’t get any Forbidden errors.

I did get an error when trying to add the code parameter, but that was a validation message saying:

The domain name entered http://pocket-inc.ml/error.php?code=403 for 403 status code appears to be invalid 5

But setting the error page without the code argument worked just fine.

1 Like