can't find the problem, 404 page not found


#1

are well elaborated here, i’m posting cars related articles, and since i’m new to websdesign i seem to have made a mistake in a certain page but i can’t figure it out, when i click the link in the index page that suppose to take me to the page it takes me instead to 404 page not found, i designed the page like the other pages i can’t find the issue this is the website go check the last article about bmw 3 series, http://autowin-dz.epizy.com


#2

Where I should click to get 404 error?


#3

the last article in the carrousel :smile:


#4

Does the file “http://autowin-dz.epizy.com/articles/bmw_srie_3_2019_photo_et_info.html” even exists on ftp?
Are you developer of this kinda CMS, you know how it works or maybe smth about rewrite rules in htaccess?


#5

yes i uploaded the page and linked it the title in the carrousel but , the page can’t be found, i did not rewrite anything in the htaccess


#6

Hi @autowin

The problem is that you do not use UTF-8 charset to name files

rename url’s in html code from ./articles/bmw_srie_3_2019_photo_et_info.html

in this ./articles/bmw_serie_3_2019_photo_et_info.html

as well as these two files


#7

and if you do not want people to see the contents of your folders
like this list http://autowin-dz.epizy.com/images/ , etc.

create in root of htdocs file named .htaccess
and put this code in it

# Disable Directory Listings in this Directory and Subdirectories
# This will hide the files from the public unless they know direct URLs
Options -Indexes

use monstaFTP (file manager) from the client area
because many text editors can add BOM or wrong charset


#8

it’s best to rename all the files and the code which uses “srie” and variations (encoded in many different charsets :neutral:

like
http://autowin-dz.epizy.com/articles/bmw_s%e9rie_3_2019_photo_et_info.css
(pay attention to the css code inside !!!)

http://autowin-dz.epizy.com/articles/images/bmw_s%e9rie_3_2019_photo_et_info_bkgrnd.png


#9

@OxyDac well :smiley: thank you so much i actually had the same thought but i told my self to just wait for an answer , and here it comes from you , i will fix it , it’s the only articles where i made the mistake , i’m glade you replied , thank you for your time and god bless you :blush:


#10

np and yw - thank you :smile:
but the answer actually gave you @MrJunior (so part of “the thank you” goes to him also)

I just gave a couple of details :smile:
if you just want to have this “special” letter e
then you need to encode it

see table with utf-8 here https://www.w3schools.com/tags/ref_urlencode.asp


#11

very helpful indeed :smiley: i will be using some of these tricks when the site start getting bigger , i need to add more pages asap :smiley: and upgrade hopefully


#12

Also if you can’t find some symbols in tables like the one OxyDac gave you, you can use console. F12 -> Console
encodeURI(string);

Example:

> encodeURI("™");
< "%E2%84%A2"

Useful for making right URL to utf8 characters.


closed #13