Certificate Not Trusted By Device

My Website Is: https://www.theofflinelibrary.ml

Here Is The Error Message That Comes Up On Google

Please Note:

This does not happen on my laptop, only on my phone.
My Certificate Was Registered On This Site Using:
Lets Encrypt
Issued by common name (CN)
For 90 Days.
Any Help Would Be Greatly Appreciated.

Recently, the DST Root CA X3 expired and thus some caused trouble. However, all certificates now should be using the ISRG Root X1. Try clicking the “Certificate Information” and look for DST Root CA X3. You can read more here:

EDIT: Your site is working fine for me.


The certificate information does not show anything like this

And it works fine on my computer, but not my phone, could it be some setting somewhere?

I found an

Wait, I found an interesting thing.
When I go to the site, it briefly shows this at the end of the site link: ?i=1
I tried visiting this and it worked.
But I want the actual original page to work, is there any way to do this?

That’s the security system, it cannot be disabled.

It means you phone’s operating system is out of date. Many operating systems released in 2017 or earlier are having trouble with the updated Let’s Encrypt certificates.

If you phone is already running the latest version of Android (presumably) that the manufacturer or your carrier provides, then you’re probably out of luck.

One option that remains is using ZeroSSL or GoGetSSL certificates instead.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.