Cloudflare

**My website URL is:**https://legacygaming-epg.epizy.com

What I’m seeing is:

I’m using this software:

**Additional information:**So i added my domain legacygaming-rpg.xyz to my forum using canel and when i type legacygaming-rpg.xyz in search bar it works all fine and it sends me to my forum but when it sends me in search bar it’s legacygaming-rpg.epizy.com instead legacygaming-rpg.xyz.

For me it’s not working, so are you trying to add the domain to CloudFlare with their nameservers while maintaining both Byet and Epizy nameservers? That is not possible, because our browsers and some DNS services don’t know where the site is found on the Internet and tries to use x nameserver, to then pass on y nameserver and then try z nameserver to then, if the DNS records are not present or aren’t correct, return an error (like DNS_PROBE_FINISHED_NXDOMAIN or the Error 1016). Please remove all nameservers from the domain registrar’s domain management panel except Cloudflare ones, then, from the topic Cloudflare shows “Error 1016: Origin DNS error”:

(optional step; if you have enabled Cloudflare from the cPanel and changed the nameservers to Cloudflare follow this step; if not don’t follow it) Go into your InfinityFree control panel and disable Cloudflare for your domain there. If you’re using Cloudflare’s nameservers, Cloudflare should be turned off in your control panel.

(recommended step) Then you can fix the records manually by first deleting all DNS records currently in Cloudflare, and you’ll want to add the following DNS records:

  • CNAME record with source @ and the target being your account’s main domain. How to find your main domain.
  • CNAME record with source www and target @ .
  • MX record with source @ and target mx.epizy.com (to receive email).
  • An additional CNAME record for every subdomain. So if you have a subdomain “blog”, you need to add a CNAME record with source blog and target @ .

After those steps, wait 24 hours for DNS propagation.