CORB 404 not found (local image)


#1

My website URL is: http://www.mariusbozhidarov.rf.gd/

What I’m seeing is: Error: “Cross-Origin Read Blocking (CORB) blocked cross-origin response https://infinityfree.net/errors/404/ with MIME type text/html.” in the console.

Additional information: The images on the “Portfolio” and “Blog” parts will not load. When I hoover over them, the link points to the right place (the img folder). I’ve tested this on USBWebServer Portable before uploading the files to the MostaFTP and everything works fine there. I’ve tried opening my website on Chrome, Firefox, Internet Explorer and Edge, but they will not load on any of them.

I’m a newbie, so I don’t know what’s going on or why CORB is even getting activated since the images are on the same subdomain.

EDIT: I hosted the images on imgur and 2 of 3 now show with no problems. The one in the “Portfolio” shows, the one in the main “Blog” page shows, but the one in the blog post itself will not, giving me the error mentioned above. From this I’m understanding that it doesn’t matter where the images actually are, but how they’re loaded. For the last, I’m using Ajax to load the html file into a div. The text and buttons load fine, except for the image. Still don’t know how to fix it though.

EDIT 2: Interestingly enough, on Internet Explorer, Edge and Opera the 3rd image does show, it only doesn’t on Chrome and Firefox.

EDIT 3: Never mind, it was the cache. Now it shows on Chrome and Firefox too. So the actual solution was to host the images on another website and now everything works fine. You can close the thread now.

P.S. Please don’t delete it though, so others may try this solution as well.


#2

The error message shows that your browser refuses to load https://infinityfree.net/errors/404/. I don’t think the problem is that the CORB settings are incorrect, but that your website is trying to load our 404 Not Found page in the first place.

If you would like to move the images back to your own website, can you please double check that the URL you’re using is correct? Because of the image URL cannot be found, that would explain the 404 error page.


#3

I see. Well, the URL for one of the images I had was “img/portfolio/p1.png” (now it’s the imgur link). As I mentioned, running the web page on a local Apache server didn’t give me any trouble. Either way, it’s OK. I’ll just leave the imgur links as they are. I don’t really have much time to work on this issue at the moment anyway, but thank you for the reply regardless.


#4

unix based systems are case sensitive
p1.png is not same as p1.PNG
http://www.mariusbozhidarov.rf.gd/img/portfolio/p1.PNG


#5

Son of a… I can’t believe it was something as simple as this. :joy:

Thank you very much. I’m going to fix it next time I update my page.