Domain forwarding

Website URL

from reinhardschleining.infinityfreeapp.com/wp

and

from
draftmagazine.infinityfreeapp.com/wp

and

systemicastrology.com
from
systemicastrology.infinityfreeapp.com/wp

Error Message

broken link icon, no page on brave or chrome

display fine in firefox focus

Other Information

have been fiddling around for many days now, trying to figure out how this dns resolving and domain forwarding works. it usually worked fine with prior free hosts or with wordpress.com itself but seemed to be ‘wobbly’? here with infinity free. tried many different things, both here or with the registrar’s settings. also looked through all the help pages and here in the forum to get my head round. no one else seemed to have this problem. was almost giving up.

i can’t connect to dns resolvers directly (that would’ve been the most obvious solution, i thought, to get more accurate and real time feedback from my change of settings). it seems the internet provider here (austria) blocks this.

but then, on a haunch, i looked for other browser alternatives. tor can’t connect to infinity, citing x-frame issues (no idea what that means).

and then i tried firefox focus - compelling in its simplicity - and it worked. it did display the infinity wp url when i enter my domain domain names. it does show me the proper forwarding. how’s this possible?

now i’m wondering what’s at work here. can anybody else on the internet see what firefox focus shows me or what brave and chrome show me (ie - nothing, lol)?

is the forwarding actually not working and firefox focus inexplicably showing me infinity cache instead?

are the dns resolvers of my provider useless? meaning, no one within their ‘area’ can see these pages? what would be a reasonable workaround, then?

(obviously, on the browser side, i’ve emptied all cache … several times even …)

thanks a lot in advance for any help or advice …

and hello to the community, btw. it seems like a really nice place here :slight_smile:

reinhard

Is there any reason why you put your website in an iFrame?

5 Likes

You may need to consider a different approach. Parking your domains could work; you can also consider adding them as addon domains and then following WordPress’s guide to move them to the new sites:

6 Likes

thanks a lot for your reply …

hm - what is an iFrame? i’m not aware of having done anything like this …?

1 Like

This is in one of your custom domain websites:

<frameset rows='100%, *' frameborder=no framespacing=0 border=0>
        <frame src="http://systemicastrology.infinityfreeapp.com/wp" name=mainwindow frameborder=no framespacing=0 marginheight=0 marginwidth=0></frame>
    </frameset>
4 Likes

hi chris, thanks a lot for looking into this. been trying to grasp these things …

basically, there are security systems in place that would prevent certain methods of accessing the infinity pages. that will explain the ‘tor’ browser problem, i guess …

i mean, generally everything works absolutely fine with my pages on the infinity address directly.

so the problem is the forwarding, no? are you saying forwarding is not possible owing to those security measures?

what would be the alternative? i already tried the custom addon domain option a few days ago in order to maybe work around this but i only ended up with more chaos. like the pages showing up as name.infinityfreeapp.comwp - a situation that i cold only solve by deleting all staging and reinstalling the wp … or by getting a “this domain is for sale” (something like this) page on the web browser …

(also still a mystery: what makes the firefox focus browser different from brave and chrome and why would brave and chrome be blocked through the infinity security system … aren’t they considered the most conventional browsers, usually?)

so this would mean i’ve installed an iFrame, you mean?

have not done this myself, must have happened somehow … don’t know how and when …

what is it doing? where is this script? can i just delete it?

i found this explanation:

and consequently added an .htaccess file both in the /htdocs and the /htdocs/wp folders, with the code as instructed there:

“Header always unset X-Frame-Options”

but it didn’t change anything …?

Do not use frames then? Simply remove your custom domains from cpanel then add them as parked domains.

4 Likes

If I may ask, is there a reason you’re installing WP in the domain.com/wp fashion (for example, http://draftmagazine.infinityfreeapp.com/wp), instead of installing them directly on http://draftmagazine.infinityfreeapp.com/? If you installed them directly on the root directory, it would be much easier to park the new domains for your sites to work as you want them to.

4 Likes

i think i’m starting to understand what you’re saying. basically, forwarding creates a frame inherently and adding my domain name with infinity (or parking it) is the more elegant way. resulting in a frameless, clean display …?

i tried both, or better i staged wp into the main directory with that great wp tool here.

it didn’t make a difference from what i could figure out, although it might have shown sometime in brave or chrome. (it’s very difficult to say often, if it is a cached result or not …).

in the end, that totally odd glitch happened that i mentioned where the browser always went to a .comwp ending and the only way to resolve this was to remove the staging.

if you’re saying installing wp directly into the htdocs directory is smoother and more elegant, then i’ll do this again. i think after staging one can ‘commit’ it to be a full install?

meanwhile, i’ve lost connection even to the ftp of the systemicastrology.infinityfreeapp.com account. has this to do with the .htacess file i added (as mentioned above)? has it been hacked? what can i do from my end to solve this???*** works again … phew

i’ve now done everything you recommended, a testrun on the systemicastrology.com site. while waiting for the dns resolvers (keeping an eye on the dnschecker.org), i wanted to explain what i’ve done as a reference. maybe it also helps other people and maybe any mistakes can be pointed out …

  1. i tried in vain to backup the site. with the plugins available, they save the data but more than 10MB files can’t be put back up at once at the server, so that option doesn’t work.

when duplicating files to the new location by hand via ftp client, this is possible but would take ages. moving is fast but then i’d lose the original.

so then the next option is export the xml of the working wp installation and importing this into clean new install. for some reason, it did not import the files, very strange. so again, this leaves me with no option to actually back up my wp files.

(although, i have not tried the softalicious backup option, i think there was one and this may well work …)

  1. so basically, i staged my /wp directory into the default /htdocs directory. have done this before and again, it worked beautifully and very fast.

  2. then i changed the dns entries with my registrar (namecheap, they seemed nice so far. moved all my domains from godaddy).

  3. until i finally added my domain as a custom domain with infinity, choosing the alias option (same /htdocs location as the new wp stage i created).

now i’ll wait and see whether this does the trick. if it does, i’d have the following questions still remaining:

  1. can i leave this staged wp as my main site? it would have the advantage that i could test things in the /wp directory and if they work i could simply restage the update …?

  2. does email forwarding work? while changing the dns settings with namecheap, they automatically disabled the email forwarding, saying this is only possible with their dns servers …?

  3. does masking still work or better yet - would i still need it, now that the domain is parked here, locally, and doesn’t really need to point anywhere else …?

in any case, thanks for all your help so far. it’s been a long day for me learning about all these options, researching what and how … if the parking (custom domain adding) works like you said, it’s definitely a paradigm change for me. from my perception, the domain was always linked to the registrar and the forwarding to different locations with masking the most obvious way to go about …

1 Like

The site you linked to works (relatively) fine for me:

What’s left now is to go to your WordPress admin dashboard and change the site URL from systemicastrology.infinityfreeapp.com to systemicastrology.com for the content to appear correctly on the new site.

I don’t see why not.

You only need to change your domain’s nameservers to InfinityFree’s to be able to add the domain to your account. After that is done, you can change your nameservers back to Namecheap’s, but you will need to create DNS records there to make the site point to this hosting.

The tutorial on how to implement Cloudflare covers the process, I’ve modified the wording a bit to match Namecheap’s platform:

This article can help as well:

8 Likes

thanks a lot for your help, really amazing. i’ve done that, changed both the wp url and domain url entries and it works! however - some of the images aren’t displayed, although when you click them, they’re present. this is happening on all browsers. (btw tor still wouldn’t show me anything). what may be the problem here? i’ve tried changing permalinks back and forth (had solved some broken link issues in the past) and also ticked and unticked the “sort media in upload date folders”. no change.

that’s incredible, thanks a lot if that works. will try this tomorrow. it’s quite a mind bender, the whole dns serving thing. unbelievable stuff …

1 Like

update: the image situation still hasn’t changed. so i keep digging :slight_smile:

i found this cloudflare dns advice with an url end-tag topic today and in the hope this may solve some issues (including possible ssl upgrading in the future …), i followed the instructions. they’re very helpful and clear.

however, i do not find the security setup option on the dashboard and the dns entries were auto generated and look like this above picture …

am i supposed to delete all entries except for the two A entries for www.systemicastrology.com and the systemicastrology.com one and change them to read “www” and “@” respectively?

then what about those ftp entries (what servers are those?) or the mx entries (can catchall emails be forwarded with cloudflare?)

and most importantly - the website doesn’t show at all again, displaying some sort of https security error (ERR_SSL_PROTOCOL_ERROR) … as i mentioned, i didn’t find anywhere the option to change those in the dashboard to allow for normal http connections instead …?

thx :slight_smile:

It’s working fine. Just wait for DNS propagation.

You can do that

No, Don’t do that. They are already setup correctly.

It’s not for me. Instead, it seems to be missing its CSS file, which probably means you have mixed content errors. (Change all internal URLs from “HTTP” to “https” - or just use relative links)

6 Likes

thank you very much for getting back on this. i’ve gone through so much in a very short period of time and i’m very aware that with any free service, any help is very kind indeed, so thanks again to the whole team here at infinityFree. this makes the space very comfortable to be a part of …

i’ve fiddled around with settings at cloudflare. leaving those for now as they are, maybe they teach me a thing or two. obviously, for the ftp i’ll still use the one address you’re giving through the control panel. have set up ‘x-plore’ which is a very versatile piece of app and the more reliable ‘ftp rush’. they have served me well and i tried a few …

cloudflare has moved the settings you showed in the youtube to something they call “page rules” and you get 3 of those rules for free still …

i did try to set up the ssl but then after losing access to my wp totally after changing to https and only being able to restore with the config.php hard code and with messed up links and browser settings - aaargh lol - i decided to live with good old http. i’ll lose my mind otherwise. this is all too crazy. too many parameter changes to consider at once at too many places …

to be honest, in terms of security, any layman hacker can access my wp and create a mess, no?

i personally think a lot of the security craze is part of the tech race, and pushed through hypocrisy. since the top-level hackers still do what they’re doing regardless of how ‘secure’ something supposedly is …

haha, anyway, for now i have to take a step back and live with good old http :slight_smile:

the image problem (not displaying) i was able to solve by adding them again in my wordpress. now they show. no idea what happened, but anyway.

what’s left now to do is apply the same treatment to my other two sites …

&

figure out how those mx entries work for the forwarding of emails.

thx again everyone :slight_smile:

It would 100% recommend HTTPS. You can follow this guide for WP:

HTTPS / TLS is secure. The exploitable vulnerabilities come from other places (namely bad and outdated code).

You will need to find an external mail provider (like Cloudflare for incoming mail). InfinityFree does not provide email services.

7 Likes

just wanted to end this topic with a big thank you
to everyone at infinityFree to help guide through this whole procedure. your work is really amazing!

i took some courage today to tackle the ssl issue, since after setting everything up with cloudflare, namecheap and here with infinityFree, (making sure all is proper), there still was odd behaviour, similar to where i started … meaning things seem to work ok on firefox focus (really cool app i think) while sometimes nothing would show on other browsers.

in the end (because oddly those other browsers always jumped to https despite having it turned off everywhere) i fiddled with the ssl settings on cloudflare. tried the flexible ssl and suddenly the pages showed (was all black before in the other browsers, although fine on firefox focus, lol). but the wordpress theme didn’t do its job. i remembered this being a problem with the url setting in wp bit it didn’t change anything. strange, i thought.

then i went for the real deal. ssl on both sides. and checked your free ssl certificate procedure. and it was then that i realized how truly amazing you guys really are …!

installed it all just by pressing three buttons. back on cloudflare i ticked ‘fixed’ (plus force https as you recommended) - and BINGO - all the pages load perfectly and quick as a flash.

what a wow :slight_smile:

really so glad i found you and made the decison to join. looked over lots of options. again, your work is amazing. and all your tutorials so crisp and clear.

wishing everyone all the best. times ahead will certainly be very interesting …

3 Likes