Email not working

https://sparkles-wiki.rf.gd/index.php

Hello, in this link or any other application installed with InfinityFree, I do not receive any email (mediawiki, support apps etc…) is there a reason why? And if possible could you help me to solve it?

Thanks <3

I don’t fully understand what you mean but I believe this is your issue.
https://forum.infinityfree.net/docs?topic=49242

4 Likes

I did read the article, and in other words it means it is normal and that therefore it isn’t possible to receive email using the infinityfree platform, right?

It is possible, you just cannot use the PHP mail() function.

Instead, use SMTP

5 Likes

I am a newbie, is there a guide of how to do this please?

I saw this How to send email with Gmail SMTP - Documentation / Email - InfinityFree Forum but it doesn’t say preciselyhow to do it, unless I did misread

I’m not using WordPress and I’m not building my website as it is installed with an app.

You have to download the zip file from the GitHub repo linked in the article.

3 Likes


what does those 2 steps means? Copy config.example.php to config.php = overwrite?

and this overwritten file should be on htdocs/contact/?

Additionally, where is the config file on the mediawiki app on the file manager?

What do you mean?

If you want to enable SMTP on media wiki, you need an SMTP plugin for MediaWiki.

That GitHub project is a SMTP contact form, not a plugin for every single software out there.

3 Likes

On the plugin on Mediawiki I found this


but is this what I’m supposed to copy to the LocalSettings.php?

Additionally, where can you find the STMP server location and what should I write for “localhost”?
Link: Manual:$wgSMTP - MediaWiki

This is what I have rn

And what device should it be for google?

Yours sincerely,

You should set it up as such:

$wgSMTP = [
    'host'      => 'smtp.gmail.com', // could also be an IP address. Where the SMTP server is located. If using SSL or TLS, add the prefix "ssl://" or "tls://".
    'IDHost'    => 'https://sparkles-wiki.rf.gd/',      // Generally this will be the domain name of your website (aka mywiki.org)
    'localhost' => 'https://sparkles-wiki.rf.gd/',      // Same as IDHost above; required by some mail servers
    'port'      => 587,                // Port to use when connecting to the SMTP server
    'auth'      => true,               // Should we use SMTP authentication (true or false)
    'username'  => 'gmail_username',     // Username to use for SMTP authentication (if being used)
    'password'  => 'google_app_password'       // Password to use for SMTP authentication (if being used)
];

In Google’s app password settings, select “Other (Custom Name)” and name it sparkles-wiki.rf.gd-MediaWiki-SMTP

4 Likes

It shows this when I ask to receive a mail

And this is the pass section

Code:

$wgSMTP = [
‘host’ => ‘smtp.gmail.com’, // could also be an IP address. Where the SMTP server is located. If using SSL or TLS, add the prefix “ssl://” or “tls://”.
‘IDHost’ => ‘https://sparkles-wiki.rf.gd/’, // Generally this will be the domain name of your website (aka mywiki.org)
‘localhost’ => ‘https://sparkles-wiki.rf.gd/’, // Same as IDHost above; required by some mail servers
‘port’ => 587, // Port to use when connecting to the SMTP server
‘auth’ => true, // Should we use SMTP authentication (true or false)
‘username’ => ‘sabry.help@gmail.com’, // Username to use for SMTP authentication (if being used)
‘password’ => ‘[HIDDEN]’ // Password to use for SMTP authentication (if being used)
];

Should be

‘username’ => ‘sabry.help’,


If the above does not work, replace

with

‘host’ => ‘tls://smtp.gmail.com’,

EDIT: Got confused with a different platform here, this should be the full email address

4 Likes

It gives this


I did both edits

Code

$wgSMTP = [
‘host’ => ‘tls://smtp.gmail.com’, // could also be an IP address. Where the SMTP server is located. If using SSL or TLS, add the prefix “ssl://” or “tls://”.
‘IDHost’ => ‘https://sparkles-wiki.rf.gd/’, // Generally this will be the domain name of your website (aka mywiki.org)
‘localhost’ => ‘https://sparkles-wiki.rf.gd/’, // Same as IDHost above; required by some mail servers
‘port’ => 587, // Port to use when connecting to the SMTP server
‘auth’ => true, // Should we use SMTP authentication (true or false)
‘username’ => ‘sabry.help’, // Username to use for SMTP authentication (if being used)
‘password’ => ‘[HIDDEN]’ // Password to use for SMTP authentication (if being used)
];

@Greenreader9

Is there anything wrong I did on the code above?

This part should be OK. But you could try ssl://smtp.gmail.com as well, Gmail supports both SSL and TLS. But omitting it also seems to work.

Looking at the comment, I would guess that this is just the domain name, not the full URL. So this should just be sparkles-wiki.rf.gd.

I think that this caused the “HELO was not accepted” error.

Pretty sure that this should be the full email address, so sabry.help@gmail.com.

3 Likes

Both the localhost and IDHost?

This is what it gives.

Code: $wgSMTP = [
    'host'      => 'ssl://smtp.gmail.com', // could also be an IP address. Where the SMTP server is located. If using SSL or TLS, add the prefix "ssl://" or "tls://".
    'IDHost'    => 'sparkles-wiki.rf.gd',      // Generally this will be the domain name of your website (aka mywiki.org)
    'localhost' => 'sparkles-wiki.rf.gd',      // Same as IDHost above; required by some mail servers
    'port'      => 587,                // Port to use when connecting to the SMTP server
    'auth'      => true,               // Should we use SMTP authentication (true or false)
    'username'  => 'sabry.help@gmail.com',     // Username to use for SMTP authentication (if being used)
    'password'  => 'HIDDEN'       // Password to use for SMTP authentication (if being used)
];

Can you try port 465? The port you are using is for TLS, but you are connecting via SSL (which looks like it is port 465).

5 Likes