FTP Error

Hi, I’m trying to backup my site via FTP, but getting this error after a while:

Response: 421 Timeout - try typing a little faster next time
Error: GnuTLS error -110 in gnutls_record_recv: The TLS connection was non-properly terminated.
Status: Server did not properly shut down TLS connection
Error: Could not read from socket: ECONNABORTED - Connection aborted
Error: Disconnected from server

This seems to be an error on the hosting side, as far as I know. My account was suspended and this started to happen after that. How can this be fixed? Thanks.

FTP connections can drop for various reasons. In this case, it means one of the FTP connections was closed by our server for inactivity. This can happen during a large transfer, because the main control connection from FileZilla is interrupted. However, this should not cause file transfers to be interrupted.

And if some files do fail to transfer, you can usually just retry the failed transfers. Usually, that’s enough to complete the full backup.


Unfortunately that’s not the case. After 10-15 seconds, every single file starts to fail. So it’s not just one file. I’ve tried it on multiple FTP clients, and on multiple desktops. This only happens on InfinityFree, all of my actions on other FTP servers work just fine.

Hmm, very strange. I’m not sure I’ve seen this issue before, and I can’t think of an immediate cause for this.

So when the connections fail, are you able to reconnect and retry transfers at all?

Did you also try this on multiple networks? One possible explanation I can come up with is that your router or ISP is dropping the connections early, so it would be useful to see if you also get this on a different network with a different ISP.

1 Like

I can reconnect and try again, but the same issue happens again. I have a VPS server in Germany, and I tried downloading the files to that desktop via remote desktop (using FileZilla) but that didn’t help either. As I’ve said, this started to happen after my account got suspended. Your panel had trouble re-enabling the service after the suspension period ended ( see Service Still Suspender After 40 Hours ) so maybe my FTP server is still suspended like the other one? Can that be the problem?

I just tried to upload a clean copy of WordPress from my own computer to your account (2k files, roughly 15 minutes to transfer), and that worked perfectly. I don’t know what’s the different between your own connection and VPS are compared to my own computer, but I cannot reproduce this issue.

Do you get this error on all files, or only on some specific ones?


Here’s a screen recording of the transfer process: https://streamable.com/a8sgd

Up - I really need a solution

Try to change encryption method to “Use only plain FTP (not secure)” on the FTP site saved through Site Manager on FileZilla and see if it still shows that error after a while.

I have no idea why connections would just break like that. And I have no way to reproduce this issue either. So I’m not sure what I can do here.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.