GoGetSSL certified, but Softaculous says "Cannot find trustworthy SSL Certificate"

Just so you dont mess up, when you set up a cloudfare account correctly, You must change the nameservers again, but dont worry about that now. Follow the Guide GreenReader made

Instead of installing again, you could backup if you have info that took a long time to make and then re upload it again to your new site.

Is everything in the ‘purchase’ and setup going well?

So far so good. Now I have the freenom domain, now starting the setup process :slight_smile:

And out of curiosity, what happens if I have the same infinityfree account linked to the rf.gd, and the new .tk? Why is it not recommended by u guys?

Keep us Updated! GL!

Alright, heads up:
On infinityfree, when I tried to register a new account, it says: “.tk domains are banned on free hosting due to abuse. To host a website without purchasing a domain name, please use a free subdomain.”

Meaning: I’m effed?

Oops, I forgot to mention… DONT USE TK DOMAINS.
I’m sorry I didn’t tell you this before!

If you want to use infinityfree with freenom, you must ‘Purchase’ a domain which is not .tk
For my website, I used .ga but you can use any other, just not .tk. So you have to purchase the domain again but not .tk It should work after that. Sorry :grimacing:

Fortunatly… No! :laughing:


.tk is kind of known for bad things…

Sorry, one of us should have thought of that.

OK, done .ga.
Now infinityfree is setting up my new account.

So now comes cloudflare, right?

Yep! Follow the guide above!

Okay so here on infinityfree I requested an SSL certificate, but says I need to set up the CNAMEs on cloudflare.
On cloudflare, I need to add the 2 records where cloudflare. type = CNAME, cloudflare.name = infinityfree.record name, and cloudflare.target = infinityfree.destination?

And also, if I scroll down, it already says I have a valid certificate installed on my domain, however, don’t I need to paste the private key and the certificate itself either here on infinityfree or on cloudflare?

Hm, can you send a screenshot of the SSL page on InfinityFree?

No, You dont need to add anothr cert. The one provided by infinityfree is enough. Just make sure your account is on. It worked for me without creating another cert

I have made the 2 records on cloudflare, if I was writing sql now, I would say cloudflare.Type = CNAME, cloudflare.Name = infinityfree.RecordName, cloudflare.content = infinityfree.Destination.

I have set up both records in cloudflare like that.

It looks like you turned on SSL on Cloudflare. Like my guide says, this is not that secure (It is more secure than nothing). I would recommend adding the cname records, copying and pasting the text, and than changing the Cloudflare SSL to “Full”.

I have that on Full (strict).
Ah figured it out. I needed to click the proxied button. Didnt realise that was a button XD

For “Full” you need to add those CNAME record than copy and paste the keys.

Have you got it all figured out?

Yep, i think so.
Now if I go on my website, in the address bar, the lock still says cloudflare certificate. Is that normal?

As a test I removed my site from cloudflare, and the proper letsencrypt certificate was showing in the padlock. And when I re-added my website, now it’s cloudflare again.

But do I understand it correctly? The fact that I see the universal cloudflare signed cert in my browser is because from the server, it goes through cloudflare, then goes to my pc, therefore my letsencrypt cert is only active between infinity server and cloudflare server, and from cloudflare to me, the cloudflare cert is used?

Basically, but Cloudflare is giving more protection than just the InfinityFree SSL.

From your description, it sounds like you got it! Great job! :clap:


Oh ok, then I get it now.
So then I presume im good now. I will try the install on this domain too, let’s see if the auto checker works now or not :smiley: