Has used all avaialble php / apache processes allowed

Username (e.g. epiz_XXX) or Website URL

epiz_28161615

Error Message

This site/page has used all avaialble php / apache processes allowed on free hosting account.

Refreshing the page once the amount of apache / php processes are reduced will cause the site to work

We would recommend upgrading your hosting account at IFastNet Premium hosting accounts , premium hosting accounts have MUCH higher resources dedicated to them.

Other Information

I’m using WordPress. I have disabled all the plugins and even put my website in maintenance mode (so it’s not possible anymore to produce a high amount of usage), I’m still getting the same error even after 1 day.

4 Likes

But this is not the error message I get. And all plugins are already disabled. Still the same

Please share your website link.

happy-students.info

You’ll probably not notice it as a regular visitor. I, as an admin, can’t edit posts or customize the theme for instance, because the edit page cannot load JS files due to this error.

1 Like

screenshot please?

were you using elementor by chance?

See this: https://imgur.com/a/lfCd8Pi. It has 3 images showing the situation

what plugins do you use? any huge themes?

Plugins (all disabled for about 1 day):

Flexible SSL for CloudFlare
Hello Dolly
Insert Headers and Footers
Page scroll to id
Post Ticker Ultimate
Really Simple SSL
Smart Slider3
WP Email SMTP
WP Forms Lite

Theme: Twenty Fifteen

P.S. Changing the theme didn’t help either

have you tried to clear your cache? Not sure why you still get it, did you logout and try again?

Just tested it on the incognito tab, unfortunately, the same

UPDATE: I needed to re-activate the website, so in order to make the admin panel functional, I manually refreshed all the pages that I get errors (as the message indicates, refreshing the page fixes the issue for one particular file).

Though, this is just a workaround and the issue still needs to be addressed IMO

It was the cache probably lmao

@jaikrishna.t No, it was not the cache. Reloading is actually the solution to this problem. In fact, you even linked the incorrect article for this issue.

@AskQue, the article below explains what is happening and why, as well as how to fix it. Please don’t hesitate to respond with any questions!

7 Likes

@Greenreader9 Thanks. I found & read this article yesterday, upon searching the error message on Google. Then I disabled all the plugins and put the website in maintenance mode - by doing so, I was intending to reduce the usage & was expecting it to get fixed by today. But that wasn’t the case, I ended up manually refreshing all JS files to make the edit page functional

4 Likes

UPDATE: The same thing happens again. All the files I recently refreshed started giving this error again. You can see some of them in the Album page. You’ll see it cannot load some images.

This is a simple WordPress site containing a lightweight theme and some well-known popular plugins. We also don’t get too many visitors, maybe a few each day. I don’t understand why it considers this as a “high usage”

Note: I have listed my plugins and theme in one of the above messages. After posting that message, I deleted WP Forms Lite and Hello Dolly.

So, the up to date list:
Plugins:
Flexible SSL for Cloudflare
Insert Headers and Footers
Page scroll to id
Post Ticker Ultimate
Really Simple SSL
Smart Slider3
WP Mail SMTP

Theme: Twenty Fifteen

I checked the Album page, and it seems that your code is causing almost 150 images to be downloaded all at the same time. Our servers have rate limiting in place to prevent people (website owners and visitors) from overloading the servers by sending a lot of requests at the same time.

So I’m sorry to say that this is intended behavior.

Please try to restructure the album pages to spread the images across more pages, and/or use image sliders that can lazy load the images as they are being accessed, instead of downloading them all at the same time.

4 Likes

use image sliders that can lazy load the images as they are being accessed

Yeah, the plugin currently doesn’t support lazy loading as we’re using the free version. I’ll look into that if this is the root cause.

I understand if it gets rate limited (which is a different situation than described in the error message) due to this, but the error message is about PHP processes and images are not PHP files, so accessing images should not run any new PHP process? Am I wrong?

There is rate limiting for files as well.

One thing I could think of that would possibly work is to combine your images into several big images and then split them apart (on the client’s machine) and load them. Otherwise, using an external image hosting website would be a great idea!

2 Likes