Help, I cannot connect to FTP

Being able to access your hosting account over FTP is very important to manage your website files. However, there are reason why you may have trouble connecting to the FTP service. This article explains a few things you can try to fix your FTP connection.

Login to your control panel

After your account has been created, or reactivated after a suspension, you may need to login to the hosting control panel once to enable FTP access to your account.

You can login to the control panel by logging in to the client area, go to the Accounts list and click Manage next to the account. Then, click the big green button which says Control Panel to login.

After this, you can try to reconnect to FTP.

Make sure you’re using the correct credentials

Double check that you are using the correct credentials for your FTP account.

You can view the credentials to use in the client area. Go to the Accounts list and click Manage next to the account. You’ll see a table with the title “FTP Details” which contains the FTP hostname, username and password.

Please note that your FTP password is NOT equal to your client area password. By default, the FTP password is randomly generated.

Change your account password

Sometimes, the hosting account password is not properly synchronized across all services. To fix this, you can change the password of your hosting account, which should force the new password to be set correctly everywhere.

To change your hosting account password, login to the client area, go to the Accounts list and click Manage next to the account. Then, click the Edit Account button and scroll down to the Hosting Account Password panel, and update your password there.

After setting the new password, login to the control panel once to ensure FTP access is enabled. After that, you can attempt to reconnect to FTP with the new password.

Check your router for FTP ALG settings

Some routers, modems or other network gateways apply a so-called Application Layer Gateway (ALG) to certain connections. An ALG intercepts regular connections from your devices to certain services on the internet, and proxies or manipulates them. In some cases, the router also has an ALG for FTP traffic. An ALG can be problematic for two reasons.

If the ALG is enabled, then the router intercepts your FTP connection and may manipulate it. This may cause unexpected issues with the FTP connection and transfers. If the FTP ALG is enabled on your router, disable it and try again.

If the ALG is not enabled, then the router might be blocking FTP connections entirely, or be configured in some other way that prevents FTP connections from being set up correctly. If your router has an FTP ALG option and it’s disabled, enable it and try again.

Check you are connecting to the right IP address

BT Internet and Plusnet in the United Kingdom (but other providers in other countries may have similar restrictions) have a Parental Control feature which is known to interfere with the connection to our FTP servers. Specifically, they block DNS queries to the FTP server name ftpupload.net.

You can check whether this is the case by checking the logs of your FTP client. If you are using FileZilla, and everything is working as it should, you should see a line like this in the logs.

Connecting to 185.27.134.11:21...

If the line shows a different IP address, it means that DNS lookups to the ftpupload.net hostname are being intercepted on your network and blocking you from accessing the FTP server.

You can work around this by using the FTP hostname ftp.epizy.com or using the IP address 185.27.134.11.

Disabling the Parental Controls on the connection should also allow you to connect to the FTP server without issues.

Try to connect with a VPN

Sometimes, network administrators or internet providers restrict or outright block FTP connections from their network. To work around this, you can use a VPN service to bypass the network restrictions of your provider.

If none of this works

If none of the tips given here work, please don’t hesitate to ask for help on our forums.

If you’re using FileZilla, be sure to add full debug logs from FileZilla to help diagnose the issue.

1 Like
Error when trying to connect to FTP
Filezilla does not connect
How can I fixed it?
Cannot log in to FTP
FTP not working in Total Commander
FTP Connection timed out after 20 seconds of inactivity
Provlem connecting via FTP
Upload failed
FTP not working
Hits Limit Suspension
FTP connection problem
Asks me for ftp access when updating / installing wp plugins
Error while connecting cyberduck to my website
Connection attempt failed with EAI_NONAME
FTP has stopped working
FTP has stopped working
Ssl remove
FTP too many failed file transfer
I can't login to my files manager
I cannot login to ftp
File Manager and FTP not working
Ftp problem
FTP: 530 Login authentication failed
Ftp connection with dreamweaver
FTP Login Issues
FTP Login Issues
FileTransfer is opening, auth failed
Cant download htdocs folder
We couldn't find that page
Problems with FTP using Filezilla
File manager login error
Not Yet Fully Propagated After 4 Days or 96 hours
Not Yet Fully Propagated After 4 Days or 96 hours
Not Yet Fully Propagated After 4 Days or 96 hours
Cannot login via ftp X multiple clients
FTP not connecting
Suspended
FTP Issues
Error in ftp connection and error to dowloads in file manager
Insecure ftp
FTP NOT working
Cant update files on website using monsta/fileZilla
How to login ftp
FTP failing
Softaculous: "Something went wrong, please allow 20 minutes then retry" on website IP 185.27.134.106
Can't connect to FTP and MYSQL even if website is ready
Can't log in to Monsta FTP/File Manager?
Can't log in to Monsta FTP/File Manager?
Can't connect FTP with Filezilla
FTP Issue
FTP Error
FTP Not Connecting
Unable to login to your FTP account. Please ensure the password in the client area is the correct pa
Plz help solve this issie
FTP file transfer
Cant log into filemanager or control panel
FTP Issue
Can't Connect To Filezilla
My ftp still not working after suspension is fixed
FTP Conection Error GNU TLS 110
Can u help me fix this problem?
Error when trying to connect to FTP
WP plugin all-in-one-wp-migration/ stops at 6 percent
Not able to connect to the website through FTP
Ftp.epizy.com is not inaccessible or Down