How do you disable https and use http only


This site can’t provide a secure connection


I want to just have http only i dont care about https or ssl

when i manually type http:// at the beginning of my webpage it works great but when i try just typeing my domain name without that it does that error(i dont use Cloudflare )

Q how to i disable the https for my domain
do i use a .htaccess to rewrite https to http

i looked over several forum questions and some of the solutions suggest cpanal options thatdon’t exist in my cpanal
here is a list of options in my cpanal

update contact email,getting started,account upgrades,account settings
online file manager,directory privacy,ftp accounts,free ftp software,backups
phpmyadmin,mysql databases,remote my sql, postgreSQL databases
addon Domains,sub domains,aliases(parked domains),redirects
email accounts,forwarders,mx entry,spf records,webmail
account statistics
ip blocker, ssl/tls
softaculous apps installer,alter php config,select php version
cron jobs,cname records,error pages
domain types,turorials, support forum

You will need to manually type HTTP. You can only redirect from HTTPS to HTTP with an SSL certificate installed.

You can’t. Since your site does not have HTTPS, an error will be shown before .htaccess can take effect (Thanks Admin, learned from my earlier mistake).

Getting an SSL certificate is quite easy, just go to and pick one. If you really don’t care, just choose “Self-Signed” than add the code below to your .htaccess file (Since the certificate will only be used to redirect to the unsecured version, they type of certificate does not matter).

NOTE: The code below wll only work if you have a valid SSL certificate

RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} =https
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Note: It is recommended that all sites have an SSL certificate. If you do not have a certificate, all your websites data is broadcasted in a way that anyone can intercept it. This means that usernames, passwords, and other sensitive data is not safe!

1 Like

i read a forum where the admin said to disable the https for your website but didnt say how,

is there a way to disable this , because i think infinity is somehow forcing https.

I help someone else with a domain on their paid hosting and their webpage is http with no security and it has none of these issues with https errors

on this forum*

InfinityFree is not, I have a few test sites that I’m working with that have no SSL and work fine.

A lot of browsers force HTTPS, since it is what you are supposed to be using, and many people to not know how unsafe HTTP really is. Getting an SSL certificate is not hard at all, and it is the easiest way to fix this issue.


i am litterly opening both my page and theirs and only mine(on infinity) is the only one showing the errors, not theirs, so if my browser was forceing it, it would force their webpage to also have ssl errors

I take that back, its now starting to come up with the same error.

my webpage worked at first but then after i refreshed it several times it then started acting up. so it seems that it happens after several tries and not right away

are you saying the browser is the problem, is there anyway to get around the browser forceing https

for other people on the internet* not me

do you think if google had my webpage that it would refer the other persons browser to always go with http(being I specified it in google analytics under URL Inspection and requested a crawl request from google with a http://

i take back what i took back. i now just tried that other webpage(not mine) again and it stopped having issues but mine has remained having issues. so why would my webpage still have issues but my friends (also http on another hoster)doesn’t have the same issues under the same browser at the same time

Why don’t you just take half an hour (With breaks) and create an SSL certificate? I don’t know of any other way to solve the issue.

1 Like

Which browser are you using? I know Firefox tries the HTTPS version first, and then loads HTTP. Maybe chrome does this too. But as @Greenreader9 said, you should take ten minutes and get an SSL certificate, it is worth it.

opera browser, i dont like the complication you have to renew it every 90 days. but can you help me understand my questions

i tried again and my freinds http webpage works fine and mine still has that error, why is theirs working and mine isnt we both use http and in the same browser.

in another post on this forum the admin said one of the solutions to this would be to “update your website configuration to not redirect people to HTTPS anymore.”
how does one do that

So do what I said before:

Get a self-signed one, and use the .htaccess code.

1 Like

A few thoughts come to mind:

  • If you have used your website with HTTPS before, your browser may have remembered that and wants to use HTTPS because it thinks your website is still capable of that. You should be able to work around this by using private browsing mode (to circumvent all caches).
  • You have a browser plugin or setting that forces HTTPS everywhere.

I have checked your website and when I try to visit it over HTTP, it loads with HTTP. Trying to access it with HTTPS shows there is no certificate installed, but nothing on your website (or on my end) is forcing HTTPS.


it didn’t happen for me at first either, it was after a day and refreshing the page many times(because i was working on things and fixing things). but i dont have the same problems with my friends page that also uses http that is on another host(not yours) . please dont be offended but i truely think that something on the infinity server is causing this hiccup, sure not at first but after several tries over a few days. something happens. and allot of people here on the forum are getting the same error

im just trying to help i super appreciate your service and need it, its and unusual issue. just trying to help

Q2 on another forum page you said this "update your website configuration to not redirect people to HTTPS anymore.” , how do you do that

But you also say that your friends don’t have this issue with your website. Why would an issue with the hosting only affect your device?

I read almost every post on the forum and I don’t know who or what posts you are talking about.

In the same way you setup forced HTTPS redirects. There are a few different approaches.

Did you add .htaccess codes for that? Then remove the .htaccess codes. Did you use a setting or plugin in your website? Then disable the option in there.

1 Like

its my friends webpage(differnet domain/different web host) vs my webpage both are http. their webpage/domain in my browser(being http) is not causing the same problem (ERR_SSL_PROTOCOL_ERROR) they are on another hoster. but in the same browser my webpage has that problem proving its not my browser that originally caused it but something else, but now that it happened the browser saw that and is now trying to do https for my webpage(im assumeing). maybe infinity server has a hiccup where it will accidently does https once somehow then my browser takes over and keeps doing it.
why is their webpage who is hosted by someone else and uses the same http work fine and mine not work is why im mentioning it here.(again thank you for the free hosting im not complaining just trying to help)

im refering to people who have the ERR_SSL_PROTOCOL_ERROR error

i was thinking of useing a htaccess but on the forum it says that you cant do it because you need a valid ssl certificate first then you can forward it to http. also I haven’t done any thing like scripts(that im aware of)except load the files on.

Oh, sorry, I thought your friends could see YOUR website with HTTP.

That said, could you perhaps ask your friends to check your website too and see if they have the same issue.

This is extremely unlikely. At no point does our server ever force HTTP or HTTPS under normal circumstances, so I don’t see how it could do that in case of an error. The only time where HTTPS is forced is because you set it up that way.

Your web page hosted with us is working fine on HTTP for me.

So I’m pretty sure it’s not the server and not your website code that’s the issue. If it was, I wouldn’t be able to open your website either.

So whatever you’re seeing, I think it’s caused by something on your end. Most likely some kind of browser cache, maybe a browser setting or plugin.

Have you tried private browsing mode already?

That usually means they want to use HTTPS but don’t have an SSL certificate yet. Your question is how you can make your website stop using HTTPS.

And for those people, the solution is simple: follow the instructions to setup HTTPS and you’re done.

1 Like