I added CNAME record but SSL doesn't work

A few days ago I added CNAME record as described in the instruction. In the name field I typed _acme-challenge, then insert destination value into its field and click the Add button (the domain was selected as it’s the only domain at the account). Once added, the name value became _acme-challenge.mydomain.com and I can’t edit it as there is no any edit button, only the Delete button. And if I try to follow by the link https://mydomain.com I still receive ERR_SSL_PROTOCOL_ERROR and only with http protocol the domain is opened. What’s wrong?

Did you add it in the SSL / TLS section

From InfinityFree SSL tool, you shd request for SSL cert.
After that, you shd copy the private key and SSL cert to SSL / TLS section.
You need to upload private first, then upload SSl cert.

This is normal. When adding the CNAME record, you have to enter the record name and the domain name separately. When the CNAME record is created, they are merged into one hostname field. So that’s all good.

And indeed, you cannot edit a CNAME record. But you can delete one record and add a new one with a different record name, domain or value.

After you’ve setup the CNAME records for Let’s Encrypt, you can click the Request SSL Certificate in the client area. After a few minutes, your SSL certificate will be created, which you can then install in your hosting account.

And only after you’ve installed the certificate will you be able to access your site with HTTPS.

When I click the Request SSL Certificate button in the client area, the current page is just scrolled to the top and nothing else happens

I try it on a tablet Lenovo, maybe this is the reason

Is the button white or blue? If it’s white, the function is disabled.

Please make sure that the CNAME records at the top of the page all show “Ready” and that there is no pending certificate request for your domain yet.

3 Likes

The button was white. I thought there is no need to add CNAME record for www-version of my website’s address if I will use only non-www version with redirect in htaccess from www to non-www. But after your mention that ALL records should have the Ready status, I added the record for www version, then the button became blue, next I generated key and certificate, paste them in their fields and now it works. Thank you for your help! Very nice support!

3 Likes

It should be important to note that while you should only have your website on either the www subdomain or on the base domain, you’ll always want a certificate which is valid for both. Suppose your website is available at https://example.com, you can redirect people coming from http://www.example.com to the secure base domain, but if someone tries to access https://www.example.com, then they’ll get an SSL error because your SSL certificate is not valid for www.example.com.

So even if you only want to redirect people, you’ll still need a valid SSL certificate.

2 Likes