I Cannot Edit My Website & It Loads Very Slow - Error 522


#1

My website URL is: https://www.soafit.com

What I’m seeing is:

I keep seeing this error whenever I want to edit a page on wordpress. Also my website loads very slow and some images don’t load up. Even though my website does load, some of the links don’t work and the Error 522 message would appear. Cloudflare says its only showing a snap shot of the website and there are issues with the hosting

I’m using this software: Using Wordpress

Additional information: My website was working great for the first two months before these issues started happening. I’ve been experiencing theses issues for about three weeks now. I’ll be grateful for any assistance. Thanks


#2

Currently I see that https://soafit.com/ works
But the WWW version has a DNS problem

Check on CloudFlare that your www leads to the same place as the root domain
and that is inside the orange cloud


#4

Thanks a lot for your assistance, my site is running fast again. I had to disconnect it from cloudflare and reconnect. The issue I’m having know is how do I get the ssl padlock back on the website? It’s been more then 24 hours and cloudflare says that my site is connected? There are no DNS issues either. Any assistance would be great. Thanks


#5

soafit.com is currently pointing to our nameservers and is not using Cloudflare. Cloudflare may have your website all set up, but if your domain isn’t using Cloudflare, that doesn’t do anything.

If you would like to use Cloudflare again, please switch your domain’s nameservers to Cloudflare.


#7

Thanks for your response. Whenever I switch the name servers to cloudflare, the errors start occurring again even though it had a pad lock on the website. When I attempt to connect cloudflare through Infinityfree control panel, an error occurs and it’s says it may be do to an account that already exist. Even if I switch my name servers to cloudflare how would the website work if its not pointing to infinityfree, since its hosting the domain? Should I create a new cloudflare account and reconnect through infinityfree? I also attempted to use the ssl generator in the control panel, but no website would sign it for a cert. Errors occur saying there or bots blocking it. Any response will be appreciated. Thanks


#8

With the CloudFlare nameservers, you need to check the DNS by yourself. The IPs which start from 185.27.134 are InfinityFree (iFastNet/Byet Internet) ones. So, you need to ping your Main Domain (which is on your Control Panel) by opening a Command Prompt (or Terminal on Mac/Linux) and typing ping yourmaindomain, replacing yourmaindomain with the domain found. Then press Ctrl and C to close the ping process and copy the IP obtained. Create new A records, one with the name of @ and another with the name of www, that point to the IP that you obtained with the orange cloud enabled and Automatic TTL (if there are already, don’t do nothing), then wait some minutes.


#10

Hello thanks for your response. I followed your directions creating new A records with the IP obtained, waited 24hrs and it still hasn’t worked. The name servers are still pointed to infinityfree though


#11

Thanks for your assistance, I was able to get my site up and running with a secure ssl pad lock. Ended up switching the name severs to cloudflares, while using infinityfrees IP address in cloudflares dns setting. So far it’s working great with no errors


#12

Hello I’m back! My website was working fine for about 4 days, but now i’m having error 522 show up again. Everything is hooked up fine on cloudflares end, so it has to be a hosting issue this time.