I cannot renew my Let's Encrypt SSL Certificate

Username (e.g. epiz_XXX) or Website URL

Asking for epiz_27039534

Error Message

Whenever I try to issue a new Let’s Encrypt Certification, it gives me the Record name and destination to put in my CName record. When I save that in my Account’s CName and try to refresh it, it just keep saying that its not verified yet. It’s been like 30 mins since I’ve done that but its still says that I need to update my CName record. I tried deleting and generating a new one but the new Destination is same as the old one even If I create the ZeroSSL or Let’s Encrypt.

Other Information

(other information and details relevant to your question)

You need to wait for dns propagation which can take up to 72 hours.

4 Likes

It also says it can take a few hours to take effect. So please just have patience, because this is normal.

I checked your latest certificate order and the correct CNAME record is detected now.

4 Likes

Thanks for the reply, but whenever I try to like verify my domain it usually ends with failed to generate SSL certificate. I don’t know what does it happens but it happened like 2-3 times with Let’s Encrypt

It ususally says : SSL certificate error: The provider returned an unknown error. Please try again later.

So I tried ZeroSSL too but it failed too with the error : SSL certificate error: The order got stuck at the provider or took too long to complete. Please try again later or try a different provider.

Common api downtime.

1 Like

I checked the logs, and it’s quite strange.

ZeroSSL tends to be a bit flaky with their API in the first place. Our system poked ZeroSSL like a dozen times to issue your certificate but it didn’t work.

Let’s Encrypt is a bit more odd though. For some reason Let’s Encrypt says that the TXT record for your domain wasn’t found, even though it’s definitely there.

I’m not sure what to make of this. You could try again later with either ZeroSSL or Let’s Encrypt, or try GoGetSSL perhaps.

3 Likes