I can't connect to my database with any scripts other than PhPMyAdmin

Username (e.g. epiz_XXX) or Website URL

User: epiz_28117295
Website: http://rmo.rf.gd/

Error Message

Warning : set_time_limit() has been disabled for security reasons in /home/vol15_1/epizy.com/epiz_28117295/htdocs/index.php on line 71

Critical Error

An error was encountered during the lifetime of the application.

This could be due to a variety of problems, such as a bug in the application.

However, normally it is caused by misconfiguration.

Exception Details

Error: Flux_Error

Message: MySQL error (SQLSTATE: 42000, ERROR: 1044): Access denied for user ‘epiz_28117295’@‘192.168.%’ to database ‘epiz_28117295_rmo’

File: /home/vol15_1/epizy.com/epiz_28117295/htdocs/modules/item/index.php:283

File Line Function/Method
/home/vol15_1/epizy.com/epiz_28117295/htdocs/lib/Flux/Template.php 375 include()
/home/vol15_1/epizy.com/epiz_28117295/htdocs/lib/Flux/Dispatcher.php 170 Flux_Template::render()
/home/vol15_1/epizy.com/epiz_28117295/htdocs/index.php 169 Flux_Dispatcher::dispatch()

Exception Trace As String

#0 /home/vol15_1/epizy.com/epiz_28117295/htdocs/lib/Flux/Template.php(375): include() #1 /home/vol15_1/epizy.com/epiz_28117295/htdocs/lib/Flux/Dispatcher.php(170): Flux_Template->render() #2 /home/vol15_1/epizy.com/epiz_28117295/htdocs/index.php(169): Flux_Dispatcher->dispatch(Array) #3 {main}

Other Information

I cannot connect to my database with any script other than PhPMyAdmin.
I have read and followed all the steps, steps and tips from this link https://support.infinityfree.net/mysql/common-mysql-errors/ and I only confirmed that my user settings, password, host and database name, which all of this information is correct in my script.

Are you sure?
Read again…

yes, absolute certainty, only my index can connect to the database, any other page inside cannot connect.

Look

My config

Host config
Screenshot_13

Db on CPanel

i’m not show password for security.

I checked your account and see you have exceeded the maximum number of inodes on your account. This means it’s not possible to create or upload new files on your account. This has the tendency to break websites too.

Please reduce your inode usage and then try again. It may just solve the issues.

2 Likes

Wow, you’re right, I didn’t realize it, I disabled the debug function of my script and I saw the problem is that it is not possible to create temporary tables, I will try to decrease the inodes and return with the result, below is a print of the new message error after updating the script.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.