Is IF support php 8 now?

Is IF support php 8 now?

Please search the forum before asking this question (this is probably the 8th or 9th time I’ve seen it in the past 6 months, no offense to you).

6 Likes

Closed because there are plenty of other resources stating that we will announce when the new PHP version comes.

Yes there are plenty questions about php 8, but sadly all the topic is closed and can’t be reply,

As a user (yes i felt offended) and human being i feel like i can’t express my oppinion because the topic is closed by someone who not opening it,.

As user and human being i want to upvote, downvote, reply, and share my opinion in the topic,.

Thanks and no offend to you :slight_smile:

What other questions do you have?

We will make an announcement when we upgrade to php8, but in the meantime, to prevent clutter, I have been telling users to please search the forum because we don’t need a million (figuratively) topic about “when will you upgrade to php8”

And I’m sorry that you felt offended, it is my bad.

4 Likes

We know you want PHP 8. Almost everyone wants PHP 8. Myself included.

But no, we don’t have it, and no, I don’t know when we will.

When we have it, we will very clearly announce this publicly, because it will be good news for almost everyone. So please keep an eye on the announcements in the forum.

Until then, please sit tight. And please refrain from asking about it over and over again, because for things like there, there is absolutely nothing new we can tell you that we haven’t announced already.

6 Likes

Is there ever gonna be an option to choose the PHP version? My old free host had the option to change between PHP 5-7 for compatibility with old scripts

I feel like I am one of the only ones who doesn’t need PHP 8.0. I have been using InfinityFree for over two years and I haven’t had a problem with the PHP version.

7 Likes

Probably not, considering that it is difficult to maintain multiple PHP stacks at once, and that most of the EOL php versions are not getting security updates (namely php5, and 7 soon) which is dangerous to the security of the servers.

We used to too. However, when php 5 was removed for compatibility reasons, we took it away. No good application should still be using php 5 for any reason. And soon (within about a year) no good application should be using php 7. PHP goes EOL pretty fast (and they tend to have many security vulnerabilities too) so you should always be trying to use the latest php version wherever possible.

5 Likes

We removed PHP 5.x, and the PHP version selector along with it, because it was very hard to keep these outdated PHP versions secure, and the way we had to run it had a large performance impact. We didn’t really anticipate these issues when the version selector was first introduced.

We can’t bring back the PHP version selector without sacrificing performance and security, which is just not something we want to do.

So don’t expect the PHP version selector to be returned any time soon. If you need old PHP versions, you need premium hosting. For everyone else, we intend to just keep one modern PHP version.

Also, in my experience, PHP 7.0 cleaned up many deprecated things that were possible (but discouraged) before. So a lot of software that was old and often poorly coded wouldn’t work with it without substantial modification. Software that works with PHP tends to work with PHP 8+ as well with little to no modifications. So I don’t expect to see that many people who need to keep PHP 7.4 because it can’t work with PHP 8.1.

4 Likes