Mail is not receiving and send mail goes to spam

I can’t see the mesaages send to my domain mail. And those I have sent to others mail goes into their spam folder. What should I do now. My domain is https://itskusum.ga

1 Like

@itskusum

do you have any email accounts? also that emails sent to spam folder is normal thing. because emails think it isn’t safe mail at all. to fix it for your email only. allow your email account to don’t know mails as an spam

Not only this, but mail is not received in my webmail when sent from gmail

Did you check the things in this article already?


It shows like this

I see now that mxtoolbox.com was maybe not the most useful link. Because what it doesn’t show clearly is that no MX record is present for your domain.

What it does show is that you’re using our Cloudflare integration, which has the known issue that it breaks basically everything except for your main website. Receiving email is one of the things it breaks.

To be able to receive email, you must disable our Cloudflare integration. After that, you can choose to continue without Cloudflare or sign up with Cloudflare yourself and use their nameservers.

1 Like

Thanks. It’s working now. But when I send mail from webmail, it goes to spam in gmail. How to fix this

1 Like

Try to mark the emails on the email address as non-spam.

Try using something like yandex or sendgrid.

If I mark as not spam then it will work only to those mails where I mark it as not spam. But how to make it as not spam in all the mails?

iFastNet doesn’t have SSL security on the free mail server. Try to use mail-tester.com to see if your emails are likely to go in the Spam or not.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.