MX Records are shown on cPanel but don't actually work

Hello,

My website: ndaeasy.co.uk
Username: epiz_28991109

I use Zoho Mail and point my MX records to their servers. It worked fine at my old registrar (Google Domains) but when I point the nameservers to InfinityFree, the MX records don’t point to Zoho from the InfinityFree cPanel.

If I use MX Lookup - Check MX Records of Domain I get the error: Search Error or NS Records not Exists. No MX record were found for the domain

I hope someone can help,
Many thanks,
Woody

pls add in cpanel and wait >= 72h

@OffensivelyKind


2

I think you use the control panel Cloudflare integration
so you have to read this

Are you using the control panel Cloudflare integration? A known issue of the control panel Cloudflare integration is that it breaks MX records (as well as custom CNAME records and subdomains). To receive email, you must disable Cloudflare on your domain name.

If you want full Cloudflare protection you best option is to move your domain to Cloudflare’s nameservers
and then there add MX and other record there.

how?

  1. turn off integrated from control panel

  2. wait at least 1 hour

  3. Creating a Cloudflare account and adding a website – Cloudflare Help Center

  4. follow further instructions by CF

3 Likes

Is there a way I could do this while staying with InfinityFree?

You’re not going anywhere
only your DNS provider will be CF and everything will go through them.
And there you add all the necessary records.


OR

3 Likes

Please disable the Cloudflare integration in the control panel and use this guide to correctly setup Cloudflare.
Thanks

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.