MX Records doesn't works

I have some issues, I have added Mx record still I am unable to add email id. The error persists " To recieve emails on the email address you will need to set the MX record for your domain name to mx.epizy.com "

From this article:

The MX records are configured correctly but you still see the notification

The notification about the MX record is always shown, regardless of the MX records configured for your domain. If you have confirmed your MX records are correct, you can safely ignore the warning.

Also, the functionality of creating email accounts and forwarders is disabled on free hosting because of spam and abuse on their servers. So, if you want to have an email account please consider using a different email provider (for that, Zoho, Migadu and Yandex offer free tiers for custom domains) or upgrading to Premium Hosting as the feature of creating email accounts and forwarders is present there, and has more features.

3 Likes

Can you send me some details to configure Zoho, Migadu, and Yandex for custom domains

For Zoho Mail, you need to have a custom TLD name that isn’t free. If you have a free domain from Freenom, this won’t work. After you are sure you have a custom not free TLD name, follow this link and these instructions from the “Sign up with a domain I already own” part. After you’ve registered successfully, you need to verify the domain name. The instructions to do that with a CNAME record are here and you need to remember to add the CNAME record from the “CNAME Records” section of the Control Panel if your domain uses our nameservers. After that you can set up the MX records from the “MX Records” section of the Control Panel, entering as name your domain name, as value mx.zoho.eu and as priority 10. Do the same thing for the other MX record, but put as value mx2.zoho.eu and as priority 20. After that it’s recommended to set up an SPF record with v=spf1 include:zoho.eu -all as value and your domain name as name, and you can do that with the “SPF Records” section of the Control Panel. Lastly, you can add your email mailboxes for your domain on the Zoho’s panel, and then access them from Zoho’s Webmail service.

For Migadu, you need to sign up here, then verify your email address and add your domain. As DNS verification method, put “Custom DNS”, and to set up the required records, you also need to use your own nameservers (even Cloudflare’s ones should do the job), as TXT records for the new verification method of Migadu aren’t supported on free hosting. After that, you need to set up the records you can find on the page you’re in on your nameservers’ DNS record management system, and after 24 hours check on Migadu the status of the DNS records. If they’re propagated, it should be verified, and now you can create as many mailboxes as you want! After that, you can access them either by using their Webmail installation or configuring your email client for that.

For Yandex, you need to sign up for Yandex.Connect. Register a new Yandex account and after that login to Yandex.Connect. From there you can add your domain, and then, with a TXT record (which isn’t supported to do on free hosting; you have to use your own nameservers for that) verify your domain ownership. After that, you can set up the MX and SPF records for Yandex.Mail and then set up your email addresses, that can be accessed by visiting the Yandex.Mail login screen and inputting as email your custom email address and as password the password you set up earlier.

But remember, only one of them, not all three, can be set up!

4 Likes

Hi, could you help me?

I’ve done the registration with Zoho, added the MX records and SPF record and disabled Cloudfare, but I’m still not receiving emails.
I’ve checked in MxToolBox and it shows the Zoho Mx records.

My site is furmidablefamily.com

If your domain is using Zoho MX records, that means any incoming email for your domain will be offered to Zoho. If that email doesn’t end up in your inbox at Zoho, then that’s an issue on Zoho’s end. Maybe Zoho’s support can help you with that instead?

2 Likes

Ok, so it’s in their end, thanks!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.