MySQL connection refused error

My website URL is: http://galaxypixel.rf.gd

What I’m seeing is: 2002 - Connection refused

I’m using this software: NamelessMC

Additional information: When I enter all of the MySQL database information to get the website installed I keep getting the error of 2002 - Connection refused. I have entered the information multiple times and in different ways and keep getting the error. Am I entering something wrong or did my database become corrupt?

What info do you give to install your site? You should share it here that we check it but please censor your password :>

1 Like

Database ip: 127.0.0.1

Database port: 3306

Database username: epiz_24900703

Database password: HIDDEN BY MOD

Database name: epiz_24900703_GalaxyPixelDataBase

Hostname: I have tried leaving it default of galaxypixel.rf.gd, I have also tried using the database hostname of sql307.epizy.com

Installation path: I have left it blank and I have put htdocs in there

Friendly URLs: disabled

Character set: unicode

Database storage engine: MyISAM

That is the problem, because you used 127.0.0.1 as database host. The correct database host can be found on the “MySQL Databases” section of the Control Panel. And uh oh! You didn’t censor the database password correctly! Change it to something else now, because it’s now compromised.

2 Likes

So I would put the host name in where the ip goes?

Would you try sql307.epizy.com as Hostname and 185.27.134.9 As database ip?

I tried what you suggested and I got error 2002 - Connection refused

Try using 192.168.0.197 as database IP, and leave the hostname and installation path as default.

@BayoDino, I don’t think the database IP you posted is correct, just because… (continues on this post)

1 Like

That works. Thank you so much!

2 Likes

185.27.134.9 is the file manager IP. The database IPs are internal IPs.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.