MySQL Databases Missing / SQL 2002 Connection Refused

Error Message

Failed to connect MySQL: PDOException: SQLSTATE[HY000] [2002] No route to host in /home/vol12_1/ Stack trace: #0 /home/vol12_1/ PDO->__construct('mysql:host=sqlxxx', 'epiz_xxxxxxxx', 'xxxxxxxxx') #1 /home/vol12_1/ connection() #2 /home/vol12_1/ require_once('/home/vol12_1/e...') #3 {main}

Other Information

When me visit my webpage, the error is show (you can see it int the top).
And when I’m open the Control Panel, i see this message :


  • When will mysql be online and working again? (In Control Panel it say few hours or less)
  • Why mysql is offline and database connection errors?

Sorry if my language is bad, I’m from Asian.

An ETA is unknown at this time. Migrations could take anywhere from a few hours (Most likely) to a few days depending on other factors.

Because, as the message says, upgrades are underway.


Thanks. :pray:

Now, database is online and can be accessed. Thanks for any helping! :grinning_face_with_smiling_eyes:

1 Like

I am now getting an an error established in database connection with this message

@Jaz_Sanchez, can you please share your domain name? If it is the one you asked for help with before, I get a different error message. Please see the below article, or let me know the correct domain name.


4 posts were split to a new topic: WordPress Error

Note the outage isn’t over.

My database is not working

The database servers are still having issues at this time.

That looks like to different error message than those associated with this outage, so if you would like more assistance, please create a new topic.


Are this error related to the topic?
Warning: PDOStatement::execute(): SQLSTATE[HY000]: General error: 1033 Incorrect information in file: ‘./epiz_xxxxxxxx_database/table.frm’ in /home/vol12_1/ on line 123

The table can’t be accessed. In PHPMyAdmin, this showed.

What is in use ?

And in phpmyadmin, i get same error :

Structure and data is lost.

Maybe? Can you please provide your epiz_xxxxxx username?




My friend also uses InfinityFree, and I asked my friend if he had the same error.
He captured screenshot the database and it’s fine.
I’m see he’s use database and tables type MyISAM, and i use InnoDB.


  1. Does InnoDB have problems and MyISAM doesn’t?
  2. Should I change my database and tables types to MyISAM?

Thank you in advance.

Well, In my side epiz_30792282, A connection timeout error of the website just occurred an hour ago today, i thought it’s just an database error, or maybe this were also caused by the currently occurring event?.. I hope so. I checked my other hosting account website and seems fine, only that one. (I hope our prof. don’t check our project while it’s at trouble😂).

iFastNet is still working on the database servers, adding more capacity and fixing issues.

I don’t know the details of what exactly they are doing, still need to do, or when they expect to do what.

All I know is that some databases may be down temporarily, and as far as I know there should not be any lasting impact on the data itself.

If there are any accounts or databases with lasting issues, I can check them and have iFastNet investigate them. But I would like to ask you first to wait at least 24 hours before reporting them, because it’s very likely that iFastNet is already aware of the issues by the time you see them and is working to fix them.

The tables of @syahid246 do actually seem to be broken. I’ve sent a request to iFastNet to look into this.


On my website, the same thing happens as the problems syahid246 is experiencing. One of my tables (kind of an important one with a lot of data in it) is “in use”. Both structure and data are lost (or at least inaccessible).
The URL is, the database username is epiz_28284116.

1 Like

I have been waiting for 24 hours, what should I do? :'D

Unfortunately there is nothing you can do.

If you have a backup, you can always try creating a new account and hope that you get placed on a functional server.

1 Like

I’m sorry for the delay @syahid246 and @MatthiasVH

I have asked iFastNet about this and it does appear that a small number of tables were corrupted during the maintenance. If one of your tables turns out to be corrupted because of this, then I’m sorry, but there is no way we can restore them.

Your only option is to delete the current tables and recreate them, either from a backup (if you have it) or from scratch.

1 Like