Navigate user to external link


#1

Hello,
I made a button on the website with
<|a href=|“https://MY_L|NK_TO_FILE_ON_EXTERNAL_WEBSITE.zip”|>BUTTON TEXT</|a>
(without |, sure)
but, when I click my button, instead of going to the external website and download file (I use Dropbox direct download), it shows me the page on the InfinityFree “404”.
I think, it trying to navigate me to that link inside InfinityFree network.
How do I make a user go to the external website by link?
Any ideas, how can I fix it?
Thank you.


#2

The link would not be found… That’s why it is going to 404 error page. To check that it’s an fault or not… Go-to cPanel- Errors- Select Domain- In 404 section write any error page… if you want… write mines - tophelper.ml/404-error

See the results and poke me out


#4

If your visitors see our error page, it likely means their browsers are looking for the page on your website, rather than the external site. Which makes me suspect the link you’re using is not pointing to what you think it does.

Can you please share the snippet of HTML code from your website with the link? Please use Markdown formatting to make sure the HTML is not rendered, rather than adding junk characters to the code.

And please try to avoid placeholder content, as the replaced content may actually contain the error.


#5

Ok, thank you.

<div class="mbr-section-btn pt-4 text-center"><a href="https://www.dropbox.com/s/jh0e4iml73oi410/MM2.zip?dl=1" class="btn btn-primary display-4">Download via Dropbox</a></div>

That’s a part of code with link and button. When I run it from PC, works nice. When I run it on InfinityFree, it navigates to 404.
(Sorry for my bad English)


#7

Ok, just tried another browser…
Why it works fine in Chrome, but doesn’t work in Edge?
I prefer Edge, so I still want to fix it.


#8

I don’t have a Windows computer, so I can’t check it in Edge myself. But your code looks fine, and so does the link on your website itself.

One possible explanation I can think of is that the Edge browser has cached an old HTML page with a broken download link. Does Edge have a private browsing mode? Does the download link work in that mode?


#9

OH, Thanks!
In private mode works fine! When I’ve cleared my Edge cache, it began to work!

P.S: Best hosting, I’ve ever seen! :slight_smile: Nice support! Good luck, InfinityFree!

Problem resolved!


#10

If the issue is resolved, please use the checkbox button at the bottom of the post with the solution to mark it as such. This means that other people with the same issue can easily tell that the problem was solved, and how it was solved!


#11

Thanks!


closed #12

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.