New account, just set up Wordpress, changed directory, now can't access it :(


#1

Just created a new InfinityFree account today, pointed netleywriters.org.uk to ns{1,2}.epizy.com on GoDaddy, installed WordPress using Softaculous default settings, did some WP setup and content creation, all good. http://netleywriters.org.uk/wp responding ok.

Then tried to make the site accessible through http://netleywriters.org.uk without the trailing /wp suffix. Used the ‘Edit’ option in Softaculous, removed /wp from URL, removed /wp from data directory name.

Now going to http://netleywriters.org.uk/ just shows InfinityFree start page same as before; http://netleywriters.org.uk/wp-admin gives 404.

Can this be recovered? Is WordPress OK with being at the top level URL? Thanks…


#2

You just had to install the WP without installation folder option which has default value set to wp, I’d recommend reinstall.


#3

I was afraid I might have to reinstall, did not want to lose the initial work of getting theme set up; hoped I could keep the existing data?


#4
Moving a WordPress installation takes a bit more effort than just changing the files. Fortunately, WordPress has documented this on their website: https://codex.wordpress.org/Moving_WordPress#Moving_Directories_On_Your_Existing_Server

But for next time, please double and triple check your settings before clicking the install button. It's easier to change a few fields on an installation form than it is to migrate a website later on.

#5

I do recall from a previous occasion tha it was quite non trivial, involving global changes of links in source files and lots of shenanigans … in this case it was a brand new installation and it was in fact easier to just ‘X’ that install and start afresh. 

But yes, for next time … look and look again before clicking Install. Good advice.


#6
I just changed my install directory yesterday.

First I edited the .htacess and script installer properties, but global database permalinks... were screwball. Undid move. Logged in, edited Admin WordPress Address (URL)... logged off, moved WP, logged in and edited home page menu permalink... Done!