Not able to send http request to connect to MySQL database

Username (e.g. epiz_XXX) or Website URL

epiz_26766462

Error Message

I am trying to send data from my esp32 (wifi module). I wrote a php code which is stored in htdocs.

When I browse the url “http://assetmanagement.epizy.com/connect.php?tag=123” then I can see the updated data in phpMyadmin.

But when I try to send the same url as HTTP GET request, data is not updated and yet no error in the connections is shown. What could be the reason?

Like you say, no PHP error, so it’s the connection to the database, in my case, I get blank pages when the MySQL query fails because it is invalid

I am sending HTTP GET request from EFP32 microcontroller. I am getting following as output on serial monitor:

HTTP Response Code: 200

This site requires Javascript to work, please enable Javascript in your browser or use a browser with Javascript support Database updated closing connection

Database is not updated and it says to enable javascript but javascript is already enabled in my browser.

Well, that shows when the system detects no javascript, and if the mictocontroller doesn’t have javascript, it won’t work.

3 Likes

So what is the solution here?
I can’t change my Microcontroller.
So does that mean I have to use a different hosting service which won’t require javascript? ( which I don’t think is possible)
But I am able to send HTTP request to other domains like api.pushingbox.com

What is a microcontroller? How does it get your sites data?

From where and to where are you sending an ajax request?

This is because of this security:

The only solution is: you must use custom domain & Cloudflare

4 Likes

Please do remember that we provide WEBSITE hosting only. If we find that you’re using our hosting as a database hosting service, that’s a violation of our terms and grounds for termination of your account.

The only RIGHT solution is to not host something like this with us.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.