Not Available Domain Freenom

Can someone fix this? I tried to contact support freenom and they won’t reply. I tried using a VPN too. It isn’t working. But, I told my Discord friend in other country to make me a domain, he can do it. Why is this happening?

We can’t fix that; it seems like Freenom is having a problem that you can only request domains from the Freenom’s Client Area after logging into it, but if you don’t have an account on there you can’t register it at the moment.

2 Likes

Maybe a browser extension is blocking system and preventing Freenom’s panel from working correctly?

1 Like

i tried deleting extension things but it wont work.

What’s the solution?

Have you attempted using a new browser, or doing a wipe?

Keep refreshing, freenoms website has been acting strange lately.

Apparently freenoms html is all garbaled up which makes navigation difficult, and it also has a lot of errors.

@MoneyBroz please do not reply to a topic in which the last post was written 2 months ago,
because what’s happening to Freenom right now is irrelevant for such an old topic.
Thank you for understanding :slight_smile:

2 Likes