Permission error while uploading image on my website

This error may occur if the image is larger than 10mb (The file limit), or the permissions are bad, but most lilkely file size.

@HaydenANG The image is 200kb.

I changed the permissions of all folders to 777, but still doesn’t work.

Weird, I have checked your website and all the links seem to work, try giving the /wp-content 755 permissions

Does it help you?


Seeing you changed the category to #other-discussions , I wanted to say this is for chit chat only, not for questions regarding Hosting/Development.
1 Like

@BayoDino No, it doesn’t work.

Did you try /wp-content 755 permissions?

@HaydenANG yes

Try these, I feel like it is one of them;

Sometimes, the “ Is its parent directory writable by the server? ” issue occurs because WordPress can’t recognize the location of the uploads folder.

2 Likes

@HaydenANG this post also contains same methods which I already used. Can I try setting all files and folders in my hosting account to 777 permission?

That’s a bit risky, but it’s up to you, if you don’t mind everyone seeing everything.

You can aslo add some changes in .htaccess for permission for user user wont be able to See that folder or link whatever.

Yep

Set the permission to 777 for all files and folders still doesn’t work.

I tried reinstalling WordPress, then it showed me this error:
Error : There was an error connecting to the server, Please verify the settings are correct.

I want to reinstall WordPress fresh, I have already backed up all important data.

Set the htdocs folder permission to default and then make sure you have uninstalled WordPress before installing it again.

@Technical.Legendz can I just click on reinstall wordpress from dashboard? Because I did that and now it’s just loading for more than 10 minutes.

I usually do it from Softaculous just in case it’s a corrupt installation.

@Technical.Legendz So what are the default permissions for htdocs folder?

755
image

It shows this error while opening Softaculous:
It appears your account has fully used it’s inode allocation, you will need to delete files to reduce inodes before the script installer will work, or upgrade to premium hosting where we offer over 400,000 inodes !

I have deleted all files and media.

1 Like