Private key doesn't work

Username (epiz_30469406) or Website URL: www.darknightcore.blog

Error Message: The private key you are trying to upload is not valid.

Other Information: the 4096-bit key when infinityfree supports 2048

It’s recommended to use https://app.infinityfree.net/sslCertificates instead.

1 Like

in fact I use that and it gives me certificates with those unsupported bits

What SSL provider are you using?

That seems unlikely. Our panel should give you a 2048 bit private key, because the control panel doesn’t support anything else.

From which certificate are you trying to install the private key? The Let’s Encrypt certificate that was issued yesterday?

1 Like

yes let’s encrypt and in any case the gogetssl certificate did not arrive

I just copy-pasted the key from the client area into the control panel and clicked upload.

It just worked. No errors and the private key is there.

Of course it didn’t, you didn’t set up the CNAME record.

1 Like

I did what she said but the key doesn’t work and I asked for the ssl 2 times
and in any case the cname for gogetssl I had put it and it didn’t arrive

What key? From my understanding you have now requested 3 different certificates across 2 different providers, so I have no clue which one you are talking about.

Admin said that he has no issues uploading your LetsEncrypt certificate, and that you did not correctly setup the CNAME records for the GoGetSSL certificate.

If you want the LetsEncrypt certificate, check the control panels SSL section, I think Admin did all the work for you. If its there, your website will work over HTTPS.

If you want the GoGetSSL certificate, you need to copy the CNAME records from EXACTLY how they appear in the client area into the control panel.

Can you please let us know what certificate you want to use?

1 Like

I’m sorry, but I have no idea what you’re trying to do and where you’re getting stuck.

I see you submitted two SSL orders for darknightcore.blog.

The first order was placed with GoGetSSL. This order cannot complete because the CNAME record is missing. If you still want that certificate, please setup the CNAME record shown there. Once you did that (and the check says Ready), leave the CNAME record there until the certificate has been issued. With GoGetSSL, this can take a few hours. But just have patience, and don’t touch anything.

You also placed an order for Let’s Encrypt. This order was completed successfully and the certificate has been issued. You are now ready to install it.

You say you had problems uploading the private key because (supposedly) it was a 4096 bits key. The key for the Let’s Encrypt certificate is 2048, and I was able to upload it without any problems. With the private key uploaded, you can now upload the corresponding certificate to make your website HTTPS capable.

I have honestly no idea what issues you’re experiencing. You have an SSL certificate which you can install.

1 Like

the panel gave me an invalid code 2 times … and they were more than 2048 bits

Than you must be doing something wrong. Can you tell us the step by step process you are doing before you got the error?

Which “they” are you talking about?

Our panel only generates 2048 bit keys. The Let’s Encrypt key is the client area is 2048 bits. I have no idea what you tried shoving into that box or where you got it, but I can guarantee you that it’s not a private key provided by us.

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.