Putenv Has been disabled

**My website URL is: http://bss-api.epizy.com

**What I’m seeing is: putenv() has been disabled for security reasons

**I’m using this software: BibleSuperSearch API

Additional information:

I am trying to install BibleSuperSearch API but I can’t because I’m getting this error. Is there possible to activate putenv for my domain?

We can’t enable putenv for security reasons on free hosting, also on your domain, because the server on where your domain is in may be affected by the change as well, and could cause hackers to abuse this service.

I’m sorry, but putenv is not and cannot be enabled on free hosting.

There are usually one of two reasons why putenv may be necessary:

  • Your software needs to set environment variables to pass to system commands. But executing system commands is blocked on our hosting entirely, so no need to have any functions which set parameters for system commands. If your software needs to do system commands, that means the software cannot be hosted on our hosting.
  • Your software uses .env files for configuration, and the developer (mistakenly) believes that the putenv function is necessary to do that. If so, this is a bug in the software, not an issue with the hosting platform.
4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.