Site https. ssl certificate

my website even after acquiring the free ssl certificate my site is still not secure

Are you using wordpress?Try to install again your site using Softaculous and put https. Note that you will have to chose the directory then go to Cloudflare and put “Flexible”

1 Like

i am not using cloudflare for the free ssl.
i am using in built infinity free ssl

You can also go to Wordpress settings and put HTTPS

Well, I recommend you cloudflare because Infinityfree doesn’t work, make sure that you don’t have a subdomain


i did but my page is still not secure

@Dancan, I checked and your website contains Resources that are served by non-secure URLs. You have to fix it by using a mixed content fixer like Really Simple SSL. Just install it like a normal plugin, enable it and click on “Go ahead, activate SSL!”. Like so you fix the mixed content errors.

6 Likes

i did but still not working

Yes, I never thought that before

Really Simple SSL is a plugin from Wordpress, try to install it.

2 Likes

To get it, just go to cloudflare, register with simple steps and select SSL and put flexible and always use HTTPS

i already installed it

You replied to the wrong person. Also, I don’t use Cloudflare for the SSL anymore; I own my server stack and so install Let’s Encrypt SSL without anything else used; just an ACME client like Certbot on the server itself. I only use Cloudflare as DNS service only.

1 Like

Use HTTP rewrite on your Cloudfare SSL/TLS dashboard.

You’re not using Cloudfare Certificate, and you’re using Let’s encrypt Authority

Maybe this could help you.

1 Like

Hello @Dancan I tried to enter your website but I don’t see anything, Google Chrome just give me error.
About HTTPS: Using Cloudflare is just a suggestion but I recommend it because it is easy to put a SSL certificate there.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.