The homepage I've created is not being displayed.


#1

My index.php isn’t loading by default instead I’m getting the “Let’s Make Something Awesome” page.
Any help is appreciated as I’m new here.


#2

I had the same problem. I created a file called “index.html” and used it has redirect to index.php which solved the problem lol


#3

you need to define the starting/home page
in .httaccess file inside of your htdocs folder

# start here
DirectoryIndex index.html 

if starting page don’t exist - make it

if you use php then index.php
if you use regular html then index.html
you choose name…

one can also do something like this

DirectoryIndex index.html index.htm index.php

server first go and check if exists index.html
if not then check index.htm
and if it does not exist, it will try to serve index.php

means what you put first


#4

@OxyDac said:
you need to define the starting/home page
in .httaccess file inside of your htdocs folder

# start here
DirectoryIndex index.html 

if starting page don’t exist - make it

if you use php then index.php
if you use regular html then index.html
you choose name…

one can also do something like this

DirectoryIndex index.html index.htm index.php

server first go and check if exists index.html
if not then check index.htm
and if it does not exist, it will try to serve index.php

means what you put first

Thanks for the information, never knew you could do this with .httaccess lol


#5

@OxyDac said:
you need to define the starting/home page
in .httaccess file inside of your htdocs folder

# start here
DirectoryIndex index.html 

if starting page don’t exist - make it

if you use php then index.php
if you use regular html then index.html
you choose name…

one can also do something like this

DirectoryIndex index.html index.htm index.php

server first go and check if exists index.html
if not then check index.htm
and if it does not exist, it will try to serve index.php

means what you put first

@OxyDac said:
you need to define the starting/home page
in .httaccess file inside of your htdocs folder

# start here
DirectoryIndex index.html 

if starting page don’t exist - make it

if you use php then index.php
if you use regular html then index.html
you choose name…

one can also do something like this

DirectoryIndex index.html index.htm index.php

server first go and check if exists index.html
if not then check index.htm
and if it does not exist, it will try to serve index.php

means what you put first

The page now loads properly on my android but the problem still exists when I try opening it using chrome on my pc


#6

Halfway there…


#7

@Lanturn Thanks for the information, never knew you could do this with .httaccess lol
np & yw - the more problem you have the more you learn

@SuryaXanden The page now loads properly on my android but the problem still exists when I try opening it using chrome on my pc

you did not give us website address to check it out, but try simply
clean chrome cache - go to your website address press F12, then CTRL + F5
or in firefox CTRL + F12


#8

@OxyDac said:
@Lanturn Thanks for the information, never knew you could do this with .httaccess lol
np & yw - the more problem you have the more you learn

@SuryaXanden The page now loads properly on my android but the problem still exists when I try opening it using chrome on my pc

you did not give us website address to check it out, but try simply
clean chrome cache - go to your website address press F12, then CTRL + F5
or in firefox CTRL + F12

http://www.suryaxanden.epizy.com/
Same problem persists on chrome incognito.


#9

If I turn on developer tools, it works :smiley: normal thing doesn’t. I still am lost tho.


#10

working here - This is an archive of PHP programs written by SuryaXanden
btw. I wrote wrong - firefox = CTRL + F5


#11

idk chrome hates me


#12

firefox ? you
haahah valentines day


#13

LOL


#14

Resetting the site preference on chrome after modding the .htacess file fixed the issue.


#15