The Weirdest Problem With HTTPS!(NOT KIDDING)


#21

Maybe try switching to Full SSL instead of Flexible?
I’ve faced similar problem to yours months ago, which posted here


#22

ADD: #508 refer to system’s resource limit (perhaps your daily hit maxed out?), try to optimize your Wordpress like what @Ranakhas stated above


#23

@Ranakhas said:

@ChrisPAR said:
@ChrisPAR said:
Weirdest Problem than ever!Now my site works,but whenever I try to login on Wordpress I receive error 508!
Can anyone give a possible explanation/solution?

Help please.
I think you should disable forcing HTTPS. Do not force traffic to HTTPS! First disable forcing then login to Dashboard change site URL from http to https this will resolve loop problem!

I already changed it from dashboard to https,but I will also try what you said about force HTTPS.


#24

@ChrisPAR said:

@Ranakhas said:

@ChrisPAR said:
@ChrisPAR said:
Weirdest Problem than ever!Now my site works,but whenever I try to login on Wordpress I receive error 508!
Can anyone give a possible explanation/solution?

Help please.
I think you should disable forcing HTTPS. Do not force traffic to HTTPS! First disable forcing then login to Dashboard change site URL from http to https this will resolve loop problem!

I already changed it from dashboard to https,but I will also try what you said about force HTTPS.

Edit:Didn’t work


#25

@ChrisPAR said:

@ChrisPAR said:

@Ranakhas said:

@ChrisPAR said:
@ChrisPAR said:
Weirdest Problem than ever!Now my site works,but whenever I try to login on Wordpress I receive error 508!
Can anyone give a possible explanation/solution?

Help please.
I think you should disable forcing HTTPS. Do not force traffic to HTTPS! First disable forcing then login to Dashboard change site URL from http to https this will resolve loop problem!

I already changed it from dashboard to https,but I will also try what you said about force HTTPS.

Edit:Didn’t work

Please help me,I dont know what’s going on,I really disabled HTTPS forcing and rewrite.


#26

@ChrisPAR said:
@ChrisPAR said:

       @ChrisPAR said:

             @Ranakhas said:
   > @ChrisPAR said:
     > @ChrisPAR said:
     >    Weirdest Problem than ever!Now my site works,but whenever I try to login on Wordpress I receive error 508!
     >    Can anyone give a possible explanation/solution?
     > 
     >
     > 
     > 
     > 
     >   Help please.
     I think you should disable forcing HTTPS. Do not force traffic to HTTPS! First disable forcing then login to Dashboard change site URL from http to https this will resolve loop problem!

 



      I already changed it from dashboard to https,but I will also try what you said about force HTTPS.





  Edit:Didn't work

Please help me,I dont know what’s going on,I really disabled HTTPS forcing and rewrite.

Kindly changes to HTTP in PHPMYADMIN than Install a plugin insecure content fixer then Capture All AJAX call


#27

Sorry but I don’t know.
Could you kindly tell me how to change it in PHPMyAdmin?
Thanks for all your help.


#28

It worked!
Even with HTTPS!
The solution was:

@Joo_Nath said:
Maybe try switching to Full SSL instead of Flexible?
I’ve faced similar problem to yours months ago, which posted here

Thank you to everybody for their help.
I thought I had changed it but I hadn’t,the problem is Flexible SSL and you MUST change it to full.
I am not sure but @Admin,could you please inform every user with an announcement that nobody should select Flexible SSL for Cloudflare(if not,I understand)?


#29

@ChrisPAR said:
It worked!
Even with HTTPS!
The solution was:

 @Joo_Nath said:

Maybe try switching to Full SSL instead of Flexible?
I’ve faced similar problem to yours months ago, which posted here

Thank you to everybody for their help.
I thought I had changed it but I hadn’t,the problem is Flexible SSL and you MUST change it to full.
I am not sure but @Admin,could you please inform every user with an announcement that nobody should select Flexible SSL for Cloudflare(if not,I understand)?

Be in mind that Cloudflare only Encrypt connection between user and Cloudflare not between user to Server thus I recommend to install Let’s Encrypt signed certificate!


#30

I understand it but I am not sure.
For now,I am okay.
Thanks again.


#31

@ChrisPAR said:
It worked!
Even with HTTPS!
The solution was:

@Joo_Nath said:
Maybe try switching to Full SSL instead of Flexible?
I’ve faced similar problem to yours months ago, which posted here

Thank you to everybody for their help.
I thought I had changed it but I hadn’t,the problem is Flexible SSL and you MUST change it to full.
I am not sure but @Admin,could you please inform every user with an announcement that nobody should select Flexible SSL for Cloudflare(if not,I understand)?

I didn’t think switching SSL modes would solve it, but I’m glad it did!

You should never use Flexible SSL on InfinityFree. Flexible SSL is only useful if the origin server does not support HTTPS. However, all websites on InfinityFree are HTTPS enabled by default, so you can always use Full SSL. Flexible SSL just leads to redirection issues like you just experienced.

@Ranakhas said:
Be in mind that Cloudflare only Encrypt connection between user and Cloudflare not between user to Server thus I recommend to install Let’s Encrypt signed certificate!

That’s the great thing about using Full SSL: it doesn’t just fix URL issues, it also ensures the connection is encrypted all the way from your visitors’ computers to your hosting account. All sites are HTTPS enabled by default, so you can have a fully encrypted connection even without having to install anything on your account.


#32

@Admin said:

@ChrisPAR said:
It worked!
Even with HTTPS!
The solution was:

@Joo_Nath said:
Maybe try switching to Full SSL instead of Flexible?
I’ve faced similar problem to yours months ago, which posted here

Thank you to everybody for their help.
I thought I had changed it but I hadn’t,the problem is Flexible SSL and you MUST change it to full.
I am not sure but @Admin,could you please inform every user with an announcement that nobody should select Flexible SSL for Cloudflare(if not,I understand)?

I didn’t think switching SSL modes would solve it, but I’m glad it did!

You should never use Flexible SSL on InfinityFree. Flexible SSL is only useful if the origin server does not support HTTPS. However, all websites on InfinityFree are HTTPS enabled by default, so you can always use Full SSL. Flexible SSL just leads to redirection issues like you just experienced.

@Ranakhas said:
Be in mind that Cloudflare only Encrypt connection between user and Cloudflare not between user to Server thus I recommend to install Let’s Encrypt signed certificate!

That’s the great thing about using Full SSL: it doesn’t just fix URL issues, it also ensures the connection is encrypted all the way from your visitors’ computers to your hosting account. All sites are HTTPS enabled by default, so you can have a fully encrypted connection even without having to install anything on your account.

Yeah but using Strict SSL may cause SSL handshake failed on Infinityfree!


#33

@Ranakhas said:

@Admin said:

@ChrisPAR said:
It worked!
Even with HTTPS!
The solution was:

@Joo_Nath said:
Maybe try switching to Full SSL instead of Flexible?
I’ve faced similar problem to yours months ago, which posted here

Thank you to everybody for their help.
I thought I had changed it but I hadn’t,the problem is Flexible SSL and you MUST change it to full.
I am not sure but @Admin,could you please inform every user with an announcement that nobody should select Flexible SSL for Cloudflare(if not,I understand)?

I didn’t think switching SSL modes would solve it, but I’m glad it did!

You should never use Flexible SSL on InfinityFree. Flexible SSL is only useful if the origin server does not support HTTPS. However, all websites on InfinityFree are HTTPS enabled by default, so you can always use Full SSL. Flexible SSL just leads to redirection issues like you just experienced.

@Ranakhas said:
Be in mind that Cloudflare only Encrypt connection between user and Cloudflare not between user to Server thus I recommend to install Let’s Encrypt signed certificate!

That’s the great thing about using Full SSL: it doesn’t just fix URL issues, it also ensures the connection is encrypted all the way from your visitors’ computers to your hosting account. All sites are HTTPS enabled by default, so you can have a fully encrypted connection even without having to install anything on your account.

Yeah but using Strict SSL may cause SSL handshake failed on Infinityfree!

If you don’t have your own SSL certificate installed, then Full Strict SSL will not work. However, Full SSL already encrypts the connection and solves redirection issues.


#34

@Admin said:

@Ranakhas said:

@Admin said:

@ChrisPAR said:
It worked!
Even with HTTPS!
The solution was:

@Joo_Nath said:
Maybe try switching to Full SSL instead of Flexible?
I’ve faced similar problem to yours months ago, which posted here

Thank you to everybody for their help.
I thought I had changed it but I hadn’t,the problem is Flexible SSL and you MUST change it to full.
I am not sure but @Admin,could you please inform every user with an announcement that nobody should select Flexible SSL for Cloudflare(if not,I understand)?

I didn’t think switching SSL modes would solve it, but I’m glad it did!

You should never use Flexible SSL on InfinityFree. Flexible SSL is only useful if the origin server does not support HTTPS. However, all websites on InfinityFree are HTTPS enabled by default, so you can always use Full SSL. Flexible SSL just leads to redirection issues like you just experienced.

@Ranakhas said:
Be in mind that Cloudflare only Encrypt connection between user and Cloudflare not between user to Server thus I recommend to install Let’s Encrypt signed certificate!

That’s the great thing about using Full SSL: it doesn’t just fix URL issues, it also ensures the connection is encrypted all the way from your visitors’ computers to your hosting account. All sites are HTTPS enabled by default, so you can have a fully encrypted connection even without having to install anything on your account.

Yeah but using Strict SSL may cause SSL handshake failed on Infinityfree!

If you don’t have your own SSL certificate installed, then Full Strict SSL will not work. However, Full SSL already encrypts the connection and solves redirection issues.

What do you mean here @Admin ?
Isn’t InfinityFree’s Free Self-Signed SSL enough for Full Strict SSL?


#35

@ChrisPAR said:

@Admin said:

@Ranakhas said:

@Admin said:

@ChrisPAR said:
It worked!
Even with HTTPS!
The solution was:

@Joo_Nath said:
Maybe try switching to Full SSL instead of Flexible?
I’ve faced similar problem to yours months ago, which posted here

Thank you to everybody for their help.
I thought I had changed it but I hadn’t,the problem is Flexible SSL and you MUST change it to full.
I am not sure but @Admin,could you please inform every user with an announcement that nobody should select Flexible SSL for Cloudflare(if not,I understand)?

I didn’t think switching SSL modes would solve it, but I’m glad it did!

You should never use Flexible SSL on InfinityFree. Flexible SSL is only useful if the origin server does not support HTTPS. However, all websites on InfinityFree are HTTPS enabled by default, so you can always use Full SSL. Flexible SSL just leads to redirection issues like you just experienced.

@Ranakhas said:
Be in mind that Cloudflare only Encrypt connection between user and Cloudflare not between user to Server thus I recommend to install Let’s Encrypt signed certificate!

That’s the great thing about using Full SSL: it doesn’t just fix URL issues, it also ensures the connection is encrypted all the way from your visitors’ computers to your hosting account. All sites are HTTPS enabled by default, so you can have a fully encrypted connection even without having to install anything on your account.

Yeah but using Strict SSL may cause SSL handshake failed on Infinityfree!

If you don’t have your own SSL certificate installed, then Full Strict SSL will not work. However, Full SSL already encrypts the connection and solves redirection issues.

What do you mean here @Admin ?
Isn’t InfinityFree’s Free Self-Signed SSL enough for Full Strict SSL?

Self Signed are not signed by a verified Certificate Authority and Full (Strict) SSL option does not work cause your origin needs to have valid certificate (not expired and signed by a trusted CA or Cloudflare Origin CA) installed. Cloudflare will connect over HTTPS and verify the cert on each request, if your site doesn’t have one this will cause a full error in your site and being completely inaccessible.


closed #36