Unable to send and receive emails

Summary

even after setting proper MX records and DNS settings, I’m still unable to send and receive emails.

Account

kapoorriya.in

Software

RoundCube Mail

Steps to reproduce

When I send an email from RoundCube webmail to other email addresses of gmail, yahoo mail and outlook mail, they don’t get delivered, also when i send emails from those email addresses to my hosted domain email addresses they don’t get delivered. I have enabled cloudflare in my cPanel and the website is accessible properly. I have created 6 email accounts on my domain out of which only 1 email account is working correctly, the other 5 email account aren’t recieving emails nor the emails sent by them are delivered.

What is the current issue behavior?

The emails don’t get delivered nor do i’am receiving emails.

What is the expected correct behavior?

The emails should be sent and received on time.

Relevant code, logs and/or screenshots

Diagnostic information for administrators:

Generating server: PU1APC01HT004.mail.protection.outlook.com
info@kapooriya.in
Remote Server returned ‘550 5.4.310 DNS domain kapooriya.in does not exist [Message=InfoDomainNonexistent] [LastAttemptedServerName=kapooriya.in] [PU1APC01FT031.eop-APC01.prod.protection.outlook.com]’
Original message headers:

DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=outlook.com;
s=selector1;
h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck;
bh=fZqSWnpnjn2nbUbjk+ZUtgKs50j1zSGZA1tU+JjWvro=;
b=YV7KtUoz9r0JKWOlbWedQBw1egby8FDI5FGqqLNUNoYkzuqYzF84q1neFENZsWd+m/PJgw43b2Vp0M+x/ui+/Ho2NHPVSidn6jdkFuIm7gUqeHf0VZ4mT5YeDZIQPfEvPblcaJ6mcITcfL9pdmm+ASgyZV7MduZpH82Nv2792mURBpxijd1B8ttXh59doxB94ZXNWuBNSVlZrlIk0RHIxv032bHx8Xm0+p/ZzA2PnZrJYcw5gAzmesCqpJHDLtXTN9rNA0LqoMWGLelrCFT7H/oAQ03iP4s1R6jPrtN3pTsnYgyE/4k00/HBTl84gIw3viMb48YMIbXKj6l/6Wv7WQ==
Received: from PU1APC01FT028.eop-APC01.prod.protection.outlook.com
(10.152.252.59) by PU1APC01HT004.eop-APC01.prod.protection.outlook.com
(10.152.252.120) with Microsoft SMTP Server (version=TLS1_2,
cipher=TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256_P256) id 15.20.906.15; Fri, 29
Jun 2018 08:39:02 +0000
Received: from HK2PR01MB1155.apcprd01.prod.exchangelabs.com (10.152.252.51) by
PU1APC01FT028.mail.protection.outlook.com (10.152.252.229) with Microsoft
SMTP Server (version=TLS1_2,
cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384_P256) id 15.20.906.15 via
Frontend Transport; Fri, 29 Jun 2018 08:39:02 +0000
Received: from HK2PR01MB1155.apcprd01.prod.exchangelabs.com
([fe80::ede6:ea41:ad82:6263]) by HK2PR01MB1155.apcprd01.prod.exchangelabs.com
([fe80::ede6:ea41:ad82:6263%2]) with mapi id 15.20.0906.023; Fri, 29 Jun 2018
08:39:02 +0000
From: Mohit Mishra mohitmishra20051996@outlook.com
To: “info@kapooriya.in” info@kapooriya.in, “connect@kapoorriya.in”
connect@kapoorriya.in, “business@kapoorriya.in” business@kapoorriya.in,
“sponsor@kapoorriya.in” sponsor@kapoorriya.in, “me@kapoorriya.in”
me@kapoorriya.in
Subject: tsthghjgh
Thread-Topic: tsthghjgh
Thread-Index: AQHUD4ShhsjqxwN4PEKllw9DL8Lnyw==
Date: Fri, 29 Jun 2018 08:39:02 +0000
Message-ID: HK2PR01MB11552FEB3D12E70B4E2D5F6CA74E0@HK2PR01MB1155.apcprd01.prod.exchangelabs.com
References: 365619309.292550.1530261526536.ref@mail.yahoo.com
Reply-To: Mohit Mishra mohitmishra20051996@outlook.com
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-clientproxiedby: SN4PR0501CA0038.namprd05.prod.outlook.com
(2603:10b6:803:41::15) To HK2PR01MB1155.apcprd01.prod.exchangelabs.com
(2603:1096:201:4::17)
x-incomingtopheadermarker: OriginalChecksum:84C25561AAE6E5CDF7AE1BD3B77CA2A277EBF7938E379931E1EF2A56F0578A8E;UpperCasedChecksum:A493F3B7C9C34E2D77408AB9C04EC4B087C083952B11A927AA420197A6CD59B2;SizeAsReceived:7569;Count:49
x-ms-exchange-messagesentrepresentingtype: 1
x-tmn: [vt+l8jwizLhg+ORWobFJyj9IjNr7sBLO]
x-ms-publictraffictype: Email
x-microsoft-exchange-diagnostics: 1;PU1APC01HT004;6:KKfuslgPx4iMJsOAhevLQ9Hno4oTcC4THmLtBJdLqLZWRJy3yTwFBShJ66HXRAM3Un/4EwnbY4fpLPtXCc7/I2T4DXdiJsCO+cEEpdT7IU781xDk3slxqpOcuK4C1QPAa71XOIWkhraLfQuCKG8driUP4IkRdu5KryTFCQvkQXINbjQcpeLIryF8xWTM3b1lJuhuiUKI3FS6lyQ0G8Sq7/cYUeACUUdhwYwuR73oEJmUvZZu61VpF4sZHyOXQ8DLZcW+hLxFNKfoW3qDDQ182W8JYqIw62tyGcKcOy5q0dKdUl9kQ/QuHe+46SKUo8U4oQv72adVn2nM0wofM3OYBZZIiNjWe7HDqtbovigJakY=;5:RTSgnfPegBrWxqGppPGQq6hL08Mfu32qIrfxx0lPoO+jiKIm1BMOP5GDtAhYpm9zoUsmueGKqFqixYhflo1u+x9Xdnd17qU/atOVo4/RqZEx+HqsGjLLoq9B/t2AAMJEYrZvoe4tEwrx2yrgibYMx2ZF7Oi7p7BE4UipChBb9aM=;24:9s6Xuabzp3qY2fCr7/6ckrXccqcs+Swn76ddqAFdH7Otz7MxDEhnOfvZrsniSFhsvJCFStGJqt/7/Q6ZuQW9AA==;7:ImEG4LFTpfseOzvwWv+GNJ1tDcynFYe3JE9hpy4898fbOXxNRK9CbPDvM48LYnhe1MwU+txEZeFfUxutrA2VXzaueB2yX2Z7bGA//95QuFziMoSkYbGm5R+H94cVnMy5unk3Z4gr1LCwBXIIY8HuS+lx6US/btGse4v4fp1sc27dX87TJr03bICgOu0ddxK2xrxgE5Hi2cp8Y6INNfxlMQtRM5u8djnqm3OmZdm/AKNZ8u09AWb7T+2c/lwVZLKG
x-incomingheadercount: 49
x-eopattributedmessage: 0
x-microsoft-antispam: UriScan:;BCL:0;PCL:0;RULEID:(7020095)(201702061078)(5061506573)(5061507331)(1603103135)(2017031320274)(2017031324274)(2017031323274)(2017031322404)(1603101448)(1601125500)(1701031045);SRVR:PU1APC01HT004;
x-ms-traffictypediagnostic: PU1APC01HT004:
x-exchange-antispam-report-cfa-test: BCL:0;PCL:0;RULEID:(444000031);SRVR:PU1APC01HT004;BCL:0;PCL:0;RULEID:;SRVR:PU1APC01HT004;
x-forefront-prvs: 0718908305
x-forefront-antispam-report: SFV:SPM;SFS:(7070007)(189003)(199004)(7696005)(446003)(74316002)(5250100002)(102836004)(221733001)(99286004)(6506007)(33656002)(386003)(68736007)(7116003)(486006)(5660300001)(43066004)(8676002)(2900100001)(8936002)(476003)(588024002)(256004)(81156014)(6346003)(87572001)(14454004)(54896002)(76176011)(1250700005)(106356001)(55016002)(555874004)(3480700004)(70282004)(105586002)(2501003)(2860700003)(6436002)(97736004)(110136005)(9686003)(26005)(86362001)(82202002)(551214005)(20460500001)(2201001)(558084003)(104016004)(25786009)(3450700001)(199113001)(133073001)(121003001)(166393002)(220243001)(421364004)(239884005)(425394004);DIR:OUT;SFP:1501;SCL:5;SRVR:PU1APC01HT004;H:HK2PR01MB1155.apcprd01.prod.exchangelabs.com;FPR:;SPF:None;PTR:InfoNoRecords;MX:1;A:1;LANG:;
received-spf: None (protection.outlook.com: outlook.com does not designate
permitted sender hosts)
authentication-results: spf=none (sender IP is )
smtp.mailfrom=mohitmishra20051996@outlook.com;
x-microsoft-antispam-message-info: RcWu4SNkn4vfBOcV0qXqa2OVmVk8S3gYE+b4LqYtSdvq0Rb2Dh4bVr0KQqowrluUPM5+NexuGzMpHkqiSAUF3KAR88eZGpdFVoGHoSC/lW6McoVujahjKBOG3XvajM+qqXZzUdiY8USr0D4/keZqIv6DDoUE7wvHPvUWRKMbnCaCuKOeaP0/BJdTnlkYkVtxw0zhkNqHb2X2MuAVoCsd2d7fZG9V1krRzY9icAh4ZbE=
Content-Type: multipart/alternative;
boundary=“000_HK2PR01MB11552FEB3D12E70B4E2D5F6CA74E0HK2PR01MB1155apcp
MIME-Version: 1.0
X-OriginatorOrg: outlook.com
X-MS-Exchange-CrossTenant-RMS-PersistedConsumerOrg: 7181d4b0-87d6-4f4e-ba33-0d3746212cec
X-MS-Exchange-CrossTenant-Network-Message-Id: 9b51dbf1-a32b-4c7d-b3e7-08d5dd9bc30b
X-MS-Exchange-CrossTenant-rms-persistedconsumerorg: 7181d4b0-87d6-4f4e-ba33-0d3746212cec
X-MS-Exchange-CrossTenant-originalarrivaltime: 29 Jun 2018 08:39:02.1950
(UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Internet
X-MS-Exchange-CrossTenant-id: 84df9e7f-e9f6-40af-b435-aaaaaaaaaaaa
X-MS-Exchange-Transport-CrossTenantHeadersStamped: PU1APC01HT004

Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

Yep, this should really be a template to people when they want to ask a questions!

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

ALSO,
All the emails account were created some 4 days ago and they were working till yesterday and 5 out of 6 email IDs stopped working from today.

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

Hello @kapoorriya,
The MX record for you to add in CloudFlare is mx.epizy.com, for InfinityFree, and email should work.
Why the sending is not working, I also don’t know, the email IDs are created in mail section and untouched right?
And, you said you enabled CloudFlare from cPanel, but when you do that you cannot modify DNS as far as I know.
Do you mean that now you use it from DNS change?

@UnknownLolz said:
Yep, this should really be a template to people when they want to ask a questions!

There has been one for a while, but people just ignored it and kept posting questions with about the same amount of information as “ur hosting is broken, plz fix”.

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

After disabling Cloudflare, please make sure to wait up to a day for the DNS changes to become visible everywhere. Both scanning the records and receiving email will not work right away.

If you’re familiar with DNS, this article should be enough to configure your DNS records properly: https://infinityfree.net/support/find-your-ip/ . If you have no idea how to put point a domain name to an IP address, then I’d highly recommend against using third party nameservers.

@ChrisPAR said:

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

Hello @kapoorriya,
The MX record for you to add in CloudFlare is mx.epizy.com, for InfinityFree, and email should work.
Why the sending is not working, I also don’t know, the email IDs are created in mail section and untouched right?
And, you said you enabled CloudFlare from cPanel, but when you do that you cannot modify DNS as far as I know.
Do you mean that now you use it from DNS change?

No the email IDs created are not untouched they were working until yesterday and they were used regularly. I entered the MX info in infinityfree’s “MX ENtry” section. When i first created an account on infinityfree i set infinityfree’s nameservers in my domain registrar 's cPanel and tried to setup CloudFlare manually from my cloudflare account but that didn’t worked as CloudFlare was asking for A,AAAA,CNAME,MX records to work and i didn’t found these records of infinityfree.net, so i activated cloudflare from my infinityfree cPanel.

And again if I disable coudflare from my infinityfree cPanel and goto my own cloudflare account to manually setup cloudflare for my website they’ll again ask for the above DNS records, you can give me these DNS records then i can disable cloudflare from my cPanel and go setup cloudflare manually to solve the email problem i’am having.

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

Hello @kapoorriya,
The MX record for you to add in CloudFlare is mx.epizy.com, for InfinityFree, and email should work.
Why the sending is not working, I also don’t know, the email IDs are created in mail section and untouched right?
And, you said you enabled CloudFlare from cPanel, but when you do that you cannot modify DNS as far as I know.
Do you mean that now you use it from DNS change?

No the email IDs created are not untouched they were working until yesterday and they were used regularly. I entered the MX info in infinityfree’s “MX ENtry” section. When i first created an account on infinityfree i set infinityfree’s nameservers in my domain registrar 's cPanel and tried to setup CloudFlare manually from my cloudflare account but that didn’t worked as CloudFlare was asking for A,AAAA,CNAME,MX records to work and i didn’t found these records of infinityfree.net, so i activated cloudflare from my infinityfree cPanel.

And again if I disable coudflare from my infinityfree cPanel and goto my own cloudflare account to manually setup cloudflare for my website they’ll again ask for the above DNS records, you can give me these DNS records then i can disable cloudflare from my cPanel and go setup cloudflare manually to solve the email problem i’am having.

Such DNS record are not so much trouble to find.
Here, you will find the option for the IP you need to enter for the A record:


And your MX record is mx.epizy.com
In both things you need to enter @ as name, and optionally www for the A record if you want your domain to be accessible with www.
Please, disable and delete CloudFlare Plan first if possible, as it will give you wrong IP for the A record.
And also, do not forget to delete the old plan of CloudFlare before you add the new one.

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

Hello @kapoorriya,
The MX record for you to add in CloudFlare is mx.epizy.com, for InfinityFree, and email should work.
Why the sending is not working, I also don’t know, the email IDs are created in mail section and untouched right?
And, you said you enabled CloudFlare from cPanel, but when you do that you cannot modify DNS as far as I know.
Do you mean that now you use it from DNS change?

No the email IDs created are not untouched they were working until yesterday and they were used regularly. I entered the MX info in infinityfree’s “MX ENtry” section. When i first created an account on infinityfree i set infinityfree’s nameservers in my domain registrar 's cPanel and tried to setup CloudFlare manually from my cloudflare account but that didn’t worked as CloudFlare was asking for A,AAAA,CNAME,MX records to work and i didn’t found these records of infinityfree.net, so i activated cloudflare from my infinityfree cPanel.

And again if I disable coudflare from my infinityfree cPanel and goto my own cloudflare account to manually setup cloudflare for my website they’ll again ask for the above DNS records, you can give me these DNS records then i can disable cloudflare from my cPanel and go setup cloudflare manually to solve the email problem i’am having.

Such DNS record are not so much trouble to find.
Here, you will find the option for the IP you need to enter for the A record:
https://infinityfree.net/support/find-your-ip/
And your MX record is mx.epizy.com
In both things you need to enter @ as name, and optionally www for the A record if you want your domain to be accessible with www.
Please, disable and delete CloudFlare Plan first if possible, as it will give you wrong IP for the A record.
And also, do not forget to delete the old plan of CloudFlare before you add the new one.

And what about the AAAA and CNAME records? cloudflare doesn’t works untill all these 4 dns records are setup there.

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

Hello @kapoorriya,
The MX record for you to add in CloudFlare is mx.epizy.com, for InfinityFree, and email should work.
Why the sending is not working, I also don’t know, the email IDs are created in mail section and untouched right?
And, you said you enabled CloudFlare from cPanel, but when you do that you cannot modify DNS as far as I know.
Do you mean that now you use it from DNS change?

No the email IDs created are not untouched they were working until yesterday and they were used regularly. I entered the MX info in infinityfree’s “MX ENtry” section. When i first created an account on infinityfree i set infinityfree’s nameservers in my domain registrar 's cPanel and tried to setup CloudFlare manually from my cloudflare account but that didn’t worked as CloudFlare was asking for A,AAAA,CNAME,MX records to work and i didn’t found these records of infinityfree.net, so i activated cloudflare from my infinityfree cPanel.

And again if I disable coudflare from my infinityfree cPanel and goto my own cloudflare account to manually setup cloudflare for my website they’ll again ask for the above DNS records, you can give me these DNS records then i can disable cloudflare from my cPanel and go setup cloudflare manually to solve the email problem i’am having.

Such DNS record are not so much trouble to find.
Here, you will find the option for the IP you need to enter for the A record:
https://infinityfree.net/support/find-your-ip/
And your MX record is mx.epizy.com
In both things you need to enter @ as name, and optionally www for the A record if you want your domain to be accessible with www.
Please, disable and delete CloudFlare Plan first if possible, as it will give you wrong IP for the A record.
And also, do not forget to delete the old plan of CloudFlare before you add the new one.

And what about the AAAA and CNAME records? cloudflare doesn’t works untill all these 4 dns records are setup there.

You really won’t need to set them up, it was not neccesary when I started a site.
I assume you have deleted old account at CloudFlare, because if not, that may be the reason.
CloudFlare always worked for me and scanned records perfectly…
You can also find AAAA records using the dig tool descried in the article before, and CNAME is not neccesary since you use A records. Can you give an image of the error you face?

even after disabling cloudflare from the cPanel and ensuring correct MX records in the cPanel, i’m still unable to receive emails.

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

Hello @kapoorriya,
The MX record for you to add in CloudFlare is mx.epizy.com, for InfinityFree, and email should work.
Why the sending is not working, I also don’t know, the email IDs are created in mail section and untouched right?
And, you said you enabled CloudFlare from cPanel, but when you do that you cannot modify DNS as far as I know.
Do you mean that now you use it from DNS change?

No the email IDs created are not untouched they were working until yesterday and they were used regularly. I entered the MX info in infinityfree’s “MX ENtry” section. When i first created an account on infinityfree i set infinityfree’s nameservers in my domain registrar 's cPanel and tried to setup CloudFlare manually from my cloudflare account but that didn’t worked as CloudFlare was asking for A,AAAA,CNAME,MX records to work and i didn’t found these records of infinityfree.net, so i activated cloudflare from my infinityfree cPanel.

And again if I disable coudflare from my infinityfree cPanel and goto my own cloudflare account to manually setup cloudflare for my website they’ll again ask for the above DNS records, you can give me these DNS records then i can disable cloudflare from my cPanel and go setup cloudflare manually to solve the email problem i’am having.

Such DNS record are not so much trouble to find.
Here, you will find the option for the IP you need to enter for the A record:
https://infinityfree.net/support/find-your-ip/
And your MX record is mx.epizy.com
In both things you need to enter @ as name, and optionally www for the A record if you want your domain to be accessible with www.
Please, disable and delete CloudFlare Plan first if possible, as it will give you wrong IP for the A record.
And also, do not forget to delete the old plan of CloudFlare before you add the new one.

And what about the AAAA and CNAME records? cloudflare doesn’t works untill all these 4 dns records are setup there.

You really won’t need to set them up, it was not neccesary when I started a site.
I assume you have deleted old account at CloudFlare, because if not, that may be the reason.
CloudFlare always worked for me and scanned records perfectly…
You can also find AAAA records using the dig tool descried in the article before, and CNAME is not neccesary since you use A records. Can you give an image of the error you face?

infinityfree says that setting up DNS records instead of using their nameservers if not recommended as the A records can change without any notice. In that case what should i do?

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

Hello @kapoorriya,
The MX record for you to add in CloudFlare is mx.epizy.com, for InfinityFree, and email should work.
Why the sending is not working, I also don’t know, the email IDs are created in mail section and untouched right?
And, you said you enabled CloudFlare from cPanel, but when you do that you cannot modify DNS as far as I know.
Do you mean that now you use it from DNS change?

No the email IDs created are not untouched they were working until yesterday and they were used regularly. I entered the MX info in infinityfree’s “MX ENtry” section. When i first created an account on infinityfree i set infinityfree’s nameservers in my domain registrar 's cPanel and tried to setup CloudFlare manually from my cloudflare account but that didn’t worked as CloudFlare was asking for A,AAAA,CNAME,MX records to work and i didn’t found these records of infinityfree.net, so i activated cloudflare from my infinityfree cPanel.

And again if I disable coudflare from my infinityfree cPanel and goto my own cloudflare account to manually setup cloudflare for my website they’ll again ask for the above DNS records, you can give me these DNS records then i can disable cloudflare from my cPanel and go setup cloudflare manually to solve the email problem i’am having.

Such DNS record are not so much trouble to find.
Here, you will find the option for the IP you need to enter for the A record:
https://infinityfree.net/support/find-your-ip/
And your MX record is mx.epizy.com
In both things you need to enter @ as name, and optionally www for the A record if you want your domain to be accessible with www.
Please, disable and delete CloudFlare Plan first if possible, as it will give you wrong IP for the A record.
And also, do not forget to delete the old plan of CloudFlare before you add the new one.

And what about the AAAA and CNAME records? cloudflare doesn’t works untill all these 4 dns records are setup there.

You really won’t need to set them up, it was not neccesary when I started a site.
I assume you have deleted old account at CloudFlare, because if not, that may be the reason.
CloudFlare always worked for me and scanned records perfectly…
You can also find AAAA records using the dig tool descried in the article before, and CNAME is not neccesary since you use A records. Can you give an image of the error you face?

infinityfree says that setting up DNS records instead of using their nameservers if not recommended as the A records can change without any notice. In that case what should i do?

Ignore the warning and proceed, its just a warning, but CloudFlare cannot work without changing NS.
If it changes, you will be able to see it and change it.

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

Hello @kapoorriya,
The MX record for you to add in CloudFlare is mx.epizy.com, for InfinityFree, and email should work.
Why the sending is not working, I also don’t know, the email IDs are created in mail section and untouched right?
And, you said you enabled CloudFlare from cPanel, but when you do that you cannot modify DNS as far as I know.
Do you mean that now you use it from DNS change?

No the email IDs created are not untouched they were working until yesterday and they were used regularly. I entered the MX info in infinityfree’s “MX ENtry” section. When i first created an account on infinityfree i set infinityfree’s nameservers in my domain registrar 's cPanel and tried to setup CloudFlare manually from my cloudflare account but that didn’t worked as CloudFlare was asking for A,AAAA,CNAME,MX records to work and i didn’t found these records of infinityfree.net, so i activated cloudflare from my infinityfree cPanel.

And again if I disable coudflare from my infinityfree cPanel and goto my own cloudflare account to manually setup cloudflare for my website they’ll again ask for the above DNS records, you can give me these DNS records then i can disable cloudflare from my cPanel and go setup cloudflare manually to solve the email problem i’am having.

Such DNS record are not so much trouble to find.
Here, you will find the option for the IP you need to enter for the A record:
https://infinityfree.net/support/find-your-ip/
And your MX record is mx.epizy.com
In both things you need to enter @ as name, and optionally www for the A record if you want your domain to be accessible with www.
Please, disable and delete CloudFlare Plan first if possible, as it will give you wrong IP for the A record.
And also, do not forget to delete the old plan of CloudFlare before you add the new one.

And what about the AAAA and CNAME records? cloudflare doesn’t works untill all these 4 dns records are setup there.

You really won’t need to set them up, it was not neccesary when I started a site.
I assume you have deleted old account at CloudFlare, because if not, that may be the reason.
CloudFlare always worked for me and scanned records perfectly…
You can also find AAAA records using the dig tool descried in the article before, and CNAME is not neccesary since you use A records. Can you give an image of the error you face?

infinityfree says that setting up DNS records instead of using their nameservers if not recommended as the A records can change without any notice. In that case what should i do?

Ignore the warning and proceed, its just a warning, but CloudFlare cannot work without changing NS.
If it changes, you will be able to see it and change it.

But why am i not able to receive the emails even after opting out of cloudflare’s service completely?

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

Hello @kapoorriya,
The MX record for you to add in CloudFlare is mx.epizy.com, for InfinityFree, and email should work.
Why the sending is not working, I also don’t know, the email IDs are created in mail section and untouched right?
And, you said you enabled CloudFlare from cPanel, but when you do that you cannot modify DNS as far as I know.
Do you mean that now you use it from DNS change?

No the email IDs created are not untouched they were working until yesterday and they were used regularly. I entered the MX info in infinityfree’s “MX ENtry” section. When i first created an account on infinityfree i set infinityfree’s nameservers in my domain registrar 's cPanel and tried to setup CloudFlare manually from my cloudflare account but that didn’t worked as CloudFlare was asking for A,AAAA,CNAME,MX records to work and i didn’t found these records of infinityfree.net, so i activated cloudflare from my infinityfree cPanel.

And again if I disable coudflare from my infinityfree cPanel and goto my own cloudflare account to manually setup cloudflare for my website they’ll again ask for the above DNS records, you can give me these DNS records then i can disable cloudflare from my cPanel and go setup cloudflare manually to solve the email problem i’am having.

Such DNS record are not so much trouble to find.
Here, you will find the option for the IP you need to enter for the A record:
https://infinityfree.net/support/find-your-ip/
And your MX record is mx.epizy.com
In both things you need to enter @ as name, and optionally www for the A record if you want your domain to be accessible with www.
Please, disable and delete CloudFlare Plan first if possible, as it will give you wrong IP for the A record.
And also, do not forget to delete the old plan of CloudFlare before you add the new one.

And what about the AAAA and CNAME records? cloudflare doesn’t works untill all these 4 dns records are setup there.

You really won’t need to set them up, it was not neccesary when I started a site.
I assume you have deleted old account at CloudFlare, because if not, that may be the reason.
CloudFlare always worked for me and scanned records perfectly…
You can also find AAAA records using the dig tool descried in the article before, and CNAME is not neccesary since you use A records. Can you give an image of the error you face?

infinityfree says that setting up DNS records instead of using their nameservers if not recommended as the A records can change without any notice. In that case what should i do?

Ignore the warning and proceed, its just a warning, but CloudFlare cannot work without changing NS.
If it changes, you will be able to see it and change it.

But why am i not able to receive the emails even after opting out of cloudflare’s service completely?

Wait for DNS propagation please. Wait at least a day before trying it again and concluding that the solution didn’t work.

Also, check the Verifying your MX Records section in this article to make sure your MX records have actually be set correctly.

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@ChrisPAR said:

@kapoorriya said:

@Admin said:
Thank you for the very detailed request! I wish everyone would include as much information as you do with their questions!

I checked your domain’s settings, and I can see already why you cannot receive email. You see, a known issue of the Cloudflare integration in the control panel is that it breaks MX records, so you cannot receive email while using the Cloudflare integration in the control panel.

Disabling Cloudflare in the control panel should allow you to receive email again. I’m not sure exactly why sending email doesn’t work, but I suspect that doing so might just fix sending email as well.

If you really want to use Cloudflare, you could sign up with them directly and use their nameservers. But you should only do so if you’re comfortable managing your own DNS records.

I tried disabling the clouflare from my cPanel and then sending emails, but still no success. Also, Cloudflare isn’t capable to scan the DNS records my my Domain, so they ask for A,AAAA, CNAME and MX records to enter manually in cloudflare’s account of mine, and i didnt found these dns records anywhere in the internet for my account on infinityfree.net

Also, when this is an issue on CloudFlare’s end then why I’am successfully able to send and receive emails from one email ID i.e. me@kapoorriya.in , rest of the email IDs aren’t working in the same way as they are expected to be.

Hello @kapoorriya,
The MX record for you to add in CloudFlare is mx.epizy.com, for InfinityFree, and email should work.
Why the sending is not working, I also don’t know, the email IDs are created in mail section and untouched right?
And, you said you enabled CloudFlare from cPanel, but when you do that you cannot modify DNS as far as I know.
Do you mean that now you use it from DNS change?

No the email IDs created are not untouched they were working until yesterday and they were used regularly. I entered the MX info in infinityfree’s “MX ENtry” section. When i first created an account on infinityfree i set infinityfree’s nameservers in my domain registrar 's cPanel and tried to setup CloudFlare manually from my cloudflare account but that didn’t worked as CloudFlare was asking for A,AAAA,CNAME,MX records to work and i didn’t found these records of infinityfree.net, so i activated cloudflare from my infinityfree cPanel.

And again if I disable coudflare from my infinityfree cPanel and goto my own cloudflare account to manually setup cloudflare for my website they’ll again ask for the above DNS records, you can give me these DNS records then i can disable cloudflare from my cPanel and go setup cloudflare manually to solve the email problem i’am having.

Such DNS record are not so much trouble to find.
Here, you will find the option for the IP you need to enter for the A record:
https://infinityfree.net/support/find-your-ip/
And your MX record is mx.epizy.com
In both things you need to enter @ as name, and optionally www for the A record if you want your domain to be accessible with www.
Please, disable and delete CloudFlare Plan first if possible, as it will give you wrong IP for the A record.
And also, do not forget to delete the old plan of CloudFlare before you add the new one.

And what about the AAAA and CNAME records? cloudflare doesn’t works untill all these 4 dns records are setup there.

Of coarse Cloudflare can’t find any AAAA Record cause they don’t even exist on your account, there were no AAAA DNS record on your account.

You will have A records though.