Why this code is not working in (only) infinityfree?

Please run this code in your computer!
Capture
The white space is working good!

But in infinityfree it’s not working

please run the same upper code in infinityfree server
It is not displaying correctly!
only one space displaying…
very saddd

You Mean You Want SSH Access? The Feature Is Not There In Free Plan.

I have updated question!

I’m No Expert In This Situation. Just Informing You.

I found a code that is working here on InfinityFree, but not with Cloudflare caching and minifying enabled for HTML code (that might cause the same problem you have). Here’s the code:

<!DOCTYPE HTML>
<html>
	<head>
		<meta charset="utf-8">
		<title>Test whitespace</title>
		<style>
			#pre {
				word-wrap: break-word;
				white-space: pre-wrap;
			}
		</style>
	</head>
	<body>
		<span id="pre">Abha      y       kuma  r</span>
	</body>
</html>

If it doesn’t work, clear your cache.

2 Likes

I have not only cleared cache but I cleared all data of browser but not working!
same data displays. only one space

Also try, if you enabled Cloudflare, on the Cloudflare dashboard in the “Speed” page, to disable Auto Minify for HTML code, so that the whitespace will work fine.

1 Like

Very very thank you!:heart:

1 Like