Wordpress-5.3.2 won't install

This is my last post.
I said the bribery part, because I thought you meant that you said I was being paid to falsely make statements about InfinityFree. I now take it back. I take back what I said (I don’t know what it is) that caused you to write the last paragraph. The fix I offered was manual installation.

Just for the record here: this is an issue on our end. I’m 98% sure that this issue is caused by the file size limit. But I haven’t gotten around to verifying this and pushing iFastNet to fix this.

This has happened in the past, and it was fixed “permanently” that time by increasing the file size limit to fit the WordPress upgrade bundle in. But if WordPress makes changes on their end which breaks it again (i.e. by increasing the archive size), that stops our permanent fix from working permanently.

(the other “permanent fix” would be to remove the file size limit entirely, which is not on the table as an option)

I would be very sad that you would discard InfinityFree in it’s entirety because one of three methods to perform one operation with one script doesn’t work anymore.

WordPress is a popular script and keeping it up to date is important, so this is something we do want to fix. But all I can say is I’ll do my best, I can’t guarantee it will be fixed at a certain date. You can demand a fix in X days, but please note that you don’t have the power to dictate what I do and when. Our free service is provided on a best effort basis, without any guarantees.

If you don’t want to wait for this undetermined amount of time to update your website, there are still two other methods to try:

  • Using Softaculous to update WordPress (if you installed the software through Softaculous or imported it afterwards).
  • Following WordPress’ official “Manual Update” procedure by uploading the new WordPress files over FTP: Updating WordPress – WordPress.org Documentation

These are of course workarounds, not fixes. You shouldn’t normally have to go through this. But it’s the best we can offer you to help you update your website right now.


I absolutely understand and support you. I’ve been having problems since last Wordpress update but amanged to restore to previous version.
Now I know what is the catch - file size limit.

For me, it works perfectly with 5.3.1 version (although that annoying notification sits whenever I log in to dashboard). And Elementor fails to update (probably again file size limit). WordPress does it on purpose. They all once they ipgrade service sky rocket size of files. Same appleis to phone Apps and phone OS updates.

That is not effective, but they are experts so they know better what can be and what cannot be done.

I still appreciate your file size limits and other limits - fair usage has to be fair usage. Those who have heavy traffic on their websites probably have commercial sites or somethign popular which they can monetize. Once they can monetize, why do they opt in for free hosting? isn’t this for students and unemployed people and those who want to test waters before we choose paid service?!


I appreciate your reply, it’s just that it came a bit late.

Softaculous doesn’t work. That’s the method I’ve been using the whole time. I’ve also tried updating from my website’s Wordpress interface and neither worked.

I kinda got fed up with waiting and being hassled by a guy who doesn’t know what they are talking about. Sure I could do the installation manually, but how would I deal with future updates when the size limit becomes a problem? Especially in light of the fact that I know I don’t have to deal with that problem with another host. I feel like this should be something you guys should be more prepared to handle, given that it’s happened in the past. I opted to just go with another free host because I really wasn’t expecting any more help and installing Wordpress wasn’t an issue with them.

The only permanent fix I can think of is to drop the file size limit entirely. But this limit was purposely implemented to enforce fair usage policies, and I don’t believe anyone is ready to just remove the limits entirely. We can increase the limit for now, but given that WordPress is continuously growing more and more fat, it’s only a matter of time until the limit is hit again.


I just did some testing, and the issue doesn’t appear to be caused by the file size limit. I was able to upload the WordPress release over FTP just fine without it getting deleted. Either iFastNet noticed the issue and increased the limit themselves since this topic was started, or there is something else going on.

Can you please confirm @rainwatr (or someone else with the same issue) that the update issues still exist?

1 Like

File size limit doesn’t have to be “eliminated”.
They could simply provide a more reasonable number, aka that gives some space.

Ya, I was going to say also that uploading by FTP wouldn’t bypass a file size limit problem, lol

As to the OP… Seriously guy, I’ve been using Free Hosts for a long time now (due to health issues and such) and this host so-far of really any has been the most generous. I mean, no other free host gives you “unlimited” Addon Domains, no ads, and so much more.

Really though, there are compomises you have to make sometimes when you have something that costs people money, but you get it free. Now, I’m of course not saying that if they provide something it should just work, but again free, things sometimes happen and you have to be patient.

True. To be honest though I don’t care for a lot of the unlimited features. The only features that matter are a reasonable amount of space for the website (something like 1 GB would suffice), access to cPanel to get the a third party ssl certificate installed, Wordpress, theme installation, plugin installation. Of course hindsight is 20/20. From hindsight I would seem impatient, given that presumably a fix came in 5 days. At the time I didn’t expect to get any help after 3 days of radio silence.

I don’t know if it’s possible but, making a filter so that most files have a file limit would maybe work. This way, things like Wordpress, Themes, and plugins, the crucial parts of a website aren’t constrained. Videos and images definitely need file size limits

@Admin I would try but I removed my website. I’d have to redirect the nameservers again to try. I could but it wouldn’t be very fast

I’m sorry I wasn’t able to investigate this issue sooner.

I agree that the basics of managing a WordPress website should just work. Large packages are pointless if you can’t do basic website administration on them. But complex operations, like installations, upgrades, imports and exports, all require a lot of server power and it’s very hard to selectively detect and whitelist such operations. And we don’t want to open the door for malicious code to slow down or bring down the service for everyone.

I like the idea, but I don’t see how a system like that could work.

Scripts, themes and plugins are basically all archives (.zip or .tar.gz or something like that). Whitelisting all archive files would defeat the point of the file size limit, because it would make it easy to offer large archives as downloads, which is definitely not what we want.

Whitelisting specific archives would be possible (based on exact signatures or something like that), but then we would need to maintain a list of signature for many CMS, themes and plugins, with every version (and maybe even multiple flavors for languages) having a different signature. That would be very hard to maintain, and cause even more vague issues.


I do not know what is the issue, but it still persists. I cannot upgrade Elementor, Elementor Addons…
Once I installed got critical error. After forceful deactivation of plugins and activation, it fails to activate Elementor It says: Warning : require(/home/vol5_3/epizy.com/epiz_24980870/htdocs/wp-content/plugins/elementor/includes/plugin.php): failed to open stream: No such file or directory in /home/vol5_3/epizy.com/epiz_24980870/htdocs/wp-content/plugins/elementor/elementor.php on line 54

Fatal error : require(): Failed opening required ‘/home/vol5_3/epizy.com/epiz_24980870/htdocs/wp-content/plugins/elementor/includes/plugin.php’ (include_path=‘.:/usr/share/pear/’) in /home/vol5_3/epizy.com/epiz_24980870/htdocs/wp-content/plugins/elementor/elementor.php on line 54

So you say this has to do nothing with file size limit?

This makes sense: if the installation was interrupted half way, then the plugins is likely corrupted, so it can’t be activated again just like that.

To fix this, you can download a fresh copy of the plugin from the official source, extract it on your own computer, and upload it to the plugins folder of your website (overwriting any files already there). That should help make sure that the plugin files are complete.

Alternatively, you could completely remove and re-install the plugin.

As far as I can tell: no, the file size limit is not the problem here.


I’ve tried installing with Wordpress with Softaculous but my domain is not listed under the Choose Domain field. I’ve already pointed the Domain name Nameservers towards ns1.epizy. com, & ns2.epizy. com and I’ve given it 2 days for propagation. Not sure what’s up

Thank you for your advice, I manually deleted plugin via File Manager and downloaded/activated fresh copy via WordPress. And now everything is up-to-date :smiley:
2 days ago.
An hour ago I got a message that my website hit the CPU limit. It is kind of running late, right? :smiley:

Now patience until tomorrow.

Maybe you should wait little more for it to become activated?

After changing the nameservers of your domain, you still need to add the domain to your hosting account. There doesn’t seem to be any domain name on your account right now. Changing the nameservers of your domain lets you verify that you are in control of the domain, but doesn’t allow us to see what you want to do with the domain.

You can add your own domain through the Addon Domains section, or create a free subdomain through the Subdomains section. Alternatively, you could just create a new account for your domain.


Ok, Wordpress installed fine. Now the theme won’t install

Installing Theme from uploaded file: Avada 6.1.2.zip

Unpacking the package…

Installing the theme…

There has been a critical error on your website. Please check your site admin email inbox for instructions.

1 Like

Also failed to install Smart Slider 3 one of the key plugins I need to build my website

Additionally certain contact form plugins won’t install either

So…Is there a solution to the plugin and theme problem or must I start another thread?