Zoho Mail - MX Record


#1

Hello there, I want to use Zoho mail in connection to the domain i own and for some reason, even after setting up everything, zoho is unable to detect the mx record i have entered in the mx record section of your hosting service. Can you please help me out with this?


#2

Not really, the MX records section does what it says on the tin. Note that it can take a few hours for Zoho to see the new records. Make sure you deleted any existing records for your domain name as well.

If it still doesn’t work, please share the domain name so I can actually check how you’ve configured it.


#3

Its still not working :frowning: My domain - www.zebrosnetwork.com


#4

I see you’re using Cloudflare through our control panel. Unfortunately, it’s a known issue that you cannot receive email when using Cloudflare that way. You could disable Cloudflare or use Cloudflare’s nameservers and set your MX records through there.


#5

Oh i see. Well, i don’t mind disabling Cloudfare but then i don’t know any other way of getting my website an ssl. I spent hours trying to figure out how self signed certificate worked but i coudnt understand how to get it done. If you could help me get https on my website without using cloudfare so that i can use zoho aswell, then it’ll be very helpful.


#6

The default certificate installed on your account is self signed, but one of the features of a self signed certificate is that it’s not trusted by browsers.

What you could do is sign up with Cloudflare directly. Disable Cloudflare in our control panel first, then sign up with Cloudflare directly and add your domain to your account there. After that, you get full DNS management at Cloudflare, including the ability to set your own MX records.


#7

Oh alright. Will do that. Thank you very much :slight_smile:


#8