CloudFlare Error 525: SSL handshake failed

My website URL is:
https://yueagar.ml/web/

What I’m seeing is:

I’m using this software:
Opera GX, Chrome

Additional information:
The website can still be accessed through http://, but I need https://
The error occurred few hours ago, and now it is still not fixed yet.
I tried to re-create the site, but it helped nothing…

1 Like

I also have this error. Website: https://www.accunews.ro

It looks like there was a system crash in the cloud system, admin will sure fix it within a day. Simillar error has occurred in the past: Error 525
There is no problem with your website setup, its the hosting provider’s issue. please be patient and im sure it will be resolved.
Best Regards

4 Likes

Thank you so much

It’s weird. Only some of domains/subdomains affected by this problem.
In my case,only my 2 domains. The others are fine.
One of those, the domain has this problem,but its subdomain is fine.

Thats because your domain uses SSL/TSS encrypted tunnels (in simple terms it has https) and infinityfree’s subdomains are unsecure plain http by default.

This is the example from my sites:
My main domain has this problem: https://www.adiworx.cf
But its subdomain is fine: https://cdn.adiworx.cf

I also have this problem. There seems to be a problem with server-side SSL negotiation.

Having same problems!

On Cloudflare side my domain used to be set to ‘Flexible’ under SSL settings. However, it looks like it was changed to Full. Changing it back to Flexible fixed it for me. (Obviously this is less secure than Full)

5 Likes

cool! this solved the issues for several of my websites affected by this problem. And I was running a facebook ad to drive visitors to my sites yesterday. What a waste.

Thanks classiccrime!

Glad to help!

If anyone else reads this and gets 302 TOO MANY REDIRECT ERRORs… Please redirect back to FULL until this issue is fixed.

More than 24 hours. It hasn’t been fixed.
Has @Admin forward this problem to iFastNet team?

I only just got a reply back from iFastNet.

I just published an outage notice with more information. This post also includes specific workaround instructions for Cloudflare:

4 Likes

bro here you can find the solution

None of these suggestions have worked!!! Please fix as soon as possible!

Thank you so much!

I’m having the same issue… no clue how long it’s been happening as its a new site that I only get to work on rarely. www.thelastfifteenyears.com & www.aneurysmrecords.com

1 Like

i am having the same problem from last 7 days !!! don’t know how much time it will take ?

It will take a while for this issue to be resolved. Which is why I wrote in my official announcement that you should really implement one of the workarounds. We’re doing our best to get the SSL fixed as soon as possible, but there are plenty of options to try if you don’t want your website to be down until that happens.

1 Like

I am also having this issue on my website.
https://www.sandawindowcleaning.co.uk/

Is there anything I can do to get this issue fixed please? Thank you.