Custom CNAME Records

Hi, my website
http://education-horaire-scolaire.infinityfreeapp.com/

I requested a free SSL certificate and am getting it from GoGetSSL. It’s pending because I need to add a CNAME
So I go to the control panel in the Custom Cname Records section, I copy-paste the name of the record, I copy-paste the destination (ending with .comodoca.com), the name of the subdomain is fine present in the drop-down list but when I click on the add button nothing happens, this button does not react. What’s wrong ? What more or less should I do ? I don’t need a domain name, a subdomain name is enough for me
Thanks for help

Hey there!
It seems there is a problem with your input.
Have you checked if all spaces [ ] are removed, so only characters are in there?
Let me know if you fix it!
Also, you can always check if you installed the SSL certificate correctly, just enter the URL. @leprincipal

5 Likes

Can you please check if you have any browser plugins or proxies that may be interfering with website functionality? You’re note the first person to report issues like this, but so far we’ve been unable to figure out what’s causing this for some users, let alone know a solution.

2 Likes

Hello
thanks for this lead. I used Firefox instead of Chrome and there the “add” button worked. As you say, probably an extension is causing this concern. I now hope that my SSL certificate will be provided to me quickly

Would you be willing to do a bit more debugging to figure out which extension that is? That knowledge can help you to use your favorite browser to access the control panel, and would help us if (or when) other people get the same issue. Or maybe even change the control panel so this issue doesn’t appear anymore.

Hello,
Okay, I’ll try to find the problem. First by removing all extensions, I have few. And we will see. I’ll keep you informed
However, I have another problem with the names of the DNS servers
I have to define them on ns1 and ns2 epizy co, I find the name of my subdomain in the “Addon Domains” section but nowhere in the control panel I can not find the place where the edit, I read your help https://support.infinityfree.net/domains-dns/how-to-use-infinityfree-nameservers/ but it sends me to another host where things are not free. Why do I need a free everything? Actually this subdomain is created to help a school in Ivory Coast and of course they are not rich so I am trying to create something that is completely free and that does not alert users that there is supposedly has a security concern.
I can see the name of the main domain, but if I try to use this URL, I am redirected to the suspended website and an offer from iFastnet to go premium, but I am not interested in this project
Well, is it possible to change these DNS server names and where for a subdomain?
Thanks for your support

No, you can’t change the nameservers of a free subdomain. Free subdomains are always hosted on our nameservers and cannot be used anywhere else.

So you can just add the CNAME records and ignore the nameserver and domain registration stuff.

3 Likes

Hello
Regarding the “Add” button, I disabled the extensions but it also didn’t work so I went into the advanced settings of Chrome and ran the “reset and clean” command and everything is returned to order even by reactivating the extensions. So I can’t explain what would go wrong.

I received my certificate this morning and everything is now in order, the site responds to the address starting with https.

Maybe we should create a help page where we clearly specify a procedure for subdomain or separate the case of a domain and the case of a subdomain because with what I found in rummaging through the help, it confuses, we have the feeling of going in circles. A different page for each case is preferable because for someone like me who has been faced with adjusting this setup for the first time, it is not obvious. Especially since it takes a certain time to receive the information concerning the certificate and that we receive warnings concerning DNS names
Thanks for your help
We can close the subject, thank you again

1 Like

One more thing, we can redirect Internet users to the https version by having an index.php file which only takes one line like this one
META http-equiv = “refresh” content = “0; URL = https: //education-horaire-scolaire.infinityfreeapp.com/pages/accueil.php
with the rafters in front and behind
You can add this solution on your page https://support.infinityfree.net/https/how-to-force-all-traffic-to-https/
and advise webmasters to use only relative links in their codes, so we should only check any external addresses

1 Like

The current set of articles is a bit spread out because most of them were written before we actually offered free SSL ourselves. A good quick start guide for each use case would indeed by a good idea.

I don’t think I can honestly recommend this approach. It has a few issues like:

  • It doesn’t redirect any other URLs. If someone navigates to http://education-horaire-scolaire.infinityfreeapp.com/pages/accueil.php , they are not redirected to HTTPS this way.
  • It doesn’t have an easy way to detect when a request is already coming in to HTTPS, it just blindly redirects everyone.
  • HTML redirects are bad for SEO. A proper HTTP response with the redirection status code 301 will also do things like force search engines to update their URLs, which doesn’t work that well with HTML or Javascript redirects.
  • It cannot be used practically if you’re using existing software. Most CMS already comes with an index.php file, and editing the source code of off the shelf software for host specific tweaks is something you should avoid.

.htaccess redirects have none of these issues. It’s clean, it’s simple, it redirects every URL and it works with every website.

If you feel that this HTML redirect suffices, then you do you. But I can’t recommend it to anyone, even to you for your site.

4 Likes

Hello,
Thanks for your explanations and I have to admit you are right.
But nothing is simple, my SSL certificate works if I access the site via its main address.
and from there the other pages are also in https but if I directly access one of my pages via http, patatras
So I tried to create the .htaccess file by simply including the 3 lines you indicate on the page https://support.infinityfree.net/https/how-to-force-all-traffic-to-https/ at know
RewriteEngine On
RewriteCond% {HTTP: X-Forwarded-Proto} = http
RewriteRule (. *) Https: //% {HTTP_HOST}% {REQUEST_URI} [L, R = 301]
I checked well if no invisible character was added at the end of the line … and therefore when I access the site via http, I get an error
“500 Error, please check your php script / enable display_errors in your cpanel”
I don’t know what to do to correct this, Sorry
Please, help me
Thanks

It’s your spacing. Shd be

RewriteCond %{HTTP:X-Forwarded-Proto} =http
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

1 Like

No, this is not the solution, I copied and pasted your code, it doesn’t change anything, but thanks