Database Connection to Website


My website URL is michaelsbookcorner(dot)com

I am working on installing and connecting Matomo Analytics to work with this website.

I’m still getting this error on the Matomo Dashboard:
Mysqli prepare error: Access denied for user ‘epiz_28063674’@‘192.168.%’ to database ‘epiz_28063674_MatomoAnalytics’ - in plugin Goals.

I did some digging regarding the establishment of a connection between my database and my website. The Matomo files are under Looking further down this path, I found the config.ini.php file →

Opening this file we have something like the following — XXX to guard the personal data. This is the opening part of the file only as there are a lot of plugins that are not relevant.
Everything seems to match, ala passwords, server, username, database name. I’m not sure where to go from this point or what to check…

; <?php exit; ?> DO NOT REMOVE THIS LINE
; file automatically generated or modified by Matomo; you can manually override the default values in global.ini.php by redefining them in this file.
host = “
username = “epiz_2806xxxx”
password = “laSXLJXXXX”
dbname = “epiz_2806xxxx_MatomoAnalytics”
tables_prefix = “matomo_”
adapter = “MYSQLI”

assume_secure_protocol = 1
proxy_client_headers[] = “HTTP_CF_CONNECTING_IP”
proxy_client_headers[] = “HTTP_X_FORWARDED_FOR”
salt = “9339db336cf01148bc229f1526c329cb”
trusted_hosts[] = “michaelsbookcorner(dot)com”

PluginsInstalled[] = “Diagnostics”
PluginsInstalled[] = “Login”
PluginsInstalled[] = “CoreAdminHome”
PluginsInstalled[] = “UsersManager”
PluginsInstalled[] = “SitesManager”

Due to this?

You need premium hosting then

1 Like

Remote MYSQL is not allowed in free hosting. It is available in premium hosting. iFastNet is recommended by InfinityFree! Bye!

Remote MySQL is probably not the problem, because that domain name seems to be hosted here.

Also, you wouldn’t get an “Access Denied” if that were the case. Most likely, you would see something like “connection refused” or “no route to host” or something like that.

My guess is it has to do with the capitalization in the database name. Database names are case sensitive, so please verify that the database name in the control panel matches the one in your configuration exactly (I would have checked for you but the control panel is currently acting up).

But it’s notable that the error is raised “in plugin Goals”. So it might also be that this plugin wants to do a type of query that is not supported on free hosting.


What is the definition of ‘external software’? I did see that notice but there is no explanation or definitions to be found.
The Matomo software is resident in files at my hosting site. Is that considered external?

If I installed the database on my personal machine would that bypass the restriction or does it matter?

Would this explain why I cannot seem to get Google Analytics or Clicky or Panel Bear to work either?


Maybe heed Admin suggestion?


Thank you for your prompt response. However, I have since attempted to start over from scratch. I deleted the folder where my Matomo files were kept. I created a new folder under and uploaded the original files again. Now, I get the friendly Matomo welcome screen but when I hit NEXT to continue the set up, I get
502 Bad Gateway. The diagram shows that I am connected to Cloudflare but then Cloudflare is not connected to Infinityfree and my files. If I connected for the first screen, then why would Matomo not already be in? I’m assuming it is still running the same setup program from within my folders at InfinityFree. There were some issues uploading the ‘plugins’ folder from Matomo. Could that be it? I’ve already installed them more than once and figured they were sound.


Please use this guide

1 Like

Right. Very well. I have been using Cloudflare with InfinityFree for quite a while with no real issues lately though my pages seem to take a long time to load.

I started over in my installation of Matomo. I scrapped the old directory and created a new one called In this folder, I uploaded all of the Matomo files/folders as instructed.
The next step was to go to to begin the installation. This time, I am using a to host the new database.
I had to try over several hours as each time I entered I kept getting a 502 Bad Gateway Error. The diagram showed my system good, Cloudflare good and no connection to InfinityFree.
Eventually, I got the first Welcome page to load from
At the next step the 502 Error Bad Gateway appeared again and was persistent.
Then I managed to get to the next page after the system check was run and was good.
After this step, I managed to get to the database info entry page, but was then stopped again by 502 Bad Gateway when I went to confirm.

Why is this connection running in such fits and starts? Why does it work one time and not the next? I’m not having this message show anywhere else I go on the web.


Looks like your account is suspended. Please visit the client area and let us know why.

I don’t know why that is.The account was only in internet jail for 24 hours. I was told that the hits were excessive for my account. The only data I have is from Cloudflare Analytics which showed a big spike at the same time. I think it was some sort of attack. I was uploading a lot of files for Matomo and had to so so more than once, but I don’t think that contributes to hit rate. Right now I am attempting to install Matomo again with another database, but the problem seems to be that at each step either the connection takes forever to make or it keep timing out with a 524 or 502 error at Infinityfree where the Matomo installation files are stored in

Probably because your website is still suspended. You are probably being affected by the DDoS attacks, but having Cloudflare setup the way you do will help.

At this point my account has not been under suspension for over 24 hours. The behavior when I try to get to the Matomo setup is the same as it was before. I keep getting 504 or 524 errors. Is there something else that could be causing the connection to fail?

I think you should try installing Matomo from Softaculous to see if that does not make problems.

When I go to the link, it looks like Matomo is not set up and I found this error:

File integrity check failed and reported some errors. You should fix this issue and then refresh this page until it shows no error.

Errors below may be due to a partial or failed upload of Matomo files.
--> Try to reupload all the Matomo files in BINARY mode. <--

File size mismatch: /home/vol11_4/ (expected length: 141829, found: 141811)
File size mismatch: /home/vol11_4/ (expected length: 3779, found: 3777)
File size mismatch: /home/vol11_4/ (expected length: 3860, found: 3858)
File size mismatch: /home/vol11_4/ (expected length: 3779, found: 3777)
File size mismatch: /home/vol11_4/ (expected length: 3210, found: 3208)
File size mismatch: /home/vol11_4/ (expected length: 3841, found: 3839)
File size mismatch: /home/vol11_4/ (expected length: 3779, found: 3777)
File size mismatch: /home/vol11_4/ (expected length: 3834, found: 3832)
File size mismatch: /home/vol11_4/ (expected length: 3815, found: 3813)
File size mismatch: /home/vol11_4/ (expected length: 3809, found: 3807)
File size mismatch: /home/vol11_4/ (expected length: 3808, found: 3806)
File size mismatch: /home/vol11_4/ (expected length: 3809, found: 3807)
File size mismatch: /home/vol11_4/ (expected length: 3194, found: 3192)
File size mismatch: /home/vol11_4/ (expected length: 3763, found: 3761)
File size mismatch: /home/vol11_4/ (expected length: 3840, found: 3838)
File size mismatch: /home/vol11_4/ (expected length: 3841, found: 3839)
File size mismatch: /home/vol11_4/ (expected length: 3841, found: 3839)
File size mismatch: /home/vol11_4/ (expected length: 3841, found: 3839)

It also says this:

    You need to enable this built-in function.
    On a high traffic website, executing the archiving process may require more time than currently allowed. 

And on any free hosting, shell_exec is disabled and on InfinityFree, set_time_limit is disabled as well.

1 Like

Probably very close to the time you found those error messages, I was repairing the file transfer as indicated by the Matomo set-up application. So far, it appears that the file uploads have been corrected. I continue to see messages of either “The database is offline” or “Database access denied”. I’ve been trying to use a database established at Infinitityfree and at another provider for mySQL. To mitigate the DDoS attacks among other firewall settings and rate limiting, I toggled their “Under Attack Mode” switch. Is it possible that all of this slowing down by Cloudflare protections could be causing time-out problems with the Matomo set-up? And how long should I leave the “Under Attack Mode” speed bump in place? 1 Week? More?

As for shell_exec or set_time_limit, I do not know what those mean. I simply wish to establish some kind of analytics for my website. Google Analytics has proved elusive, though Google Tag Manager has proven to work with Pinterest Tags thus far. It is still early. Cloudflare provides some Web Analytics data, but it is too early to tell if it is accurate My website, other than the two DDoS attacks suffered in quick succession were the only thing resembling high traffic. The whole point of wanting to see analytics data was to drive legitimate traffic.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.