index problem How do I disable directory listing?


#1

hello guys

my site www.blogcunuz.ml/wp/

www.blogcunuz.ml directory listing i wanna see my site on homepage .ml

wordpress settings done what i need? change htaccess?


#2

my htcaccess

BEGIN WordPress

RewriteEngine On RewriteBase / RewriteRule ^index\\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] # END WordPress

Options - Indexes

still dont working www.blogcunuz.ml :frowning:


#3

@blogcnuzz said:
hello guys

my site www.blogcunuz.ml/wp/

www.blogcunuz.ml directory listing i wanna see my site on homepage .ml

wordpress settings done what i need? change htaccess?

Just add Option -Indexes on your htacces


#4

@blogcnuzz said:
hello guys

my site www.blogcunuz.ml/wp/

www.blogcunuz.ml directory listing i wanna see my site on homepage .ml

wordpress settings done what i need? change htaccess?

Your Address is still www.blogcunuz.ml/wp/ but now www.blogcunuz.ml is redirecting to www.blogcunuz.ml/wp/ I suggest you to move your files from /wp/ to htdocs main folder then update your site name in PHPMYADMIN SQL in wp_options change siteURL from www.blogcunuz.ml/wp/ to www.blogcunuz.ml also do this with homepageURL from www.blogcunuz.ml/wp/ to www.blogcunuz.ml

Or

First update URL in General Setting in WP-Dashboard then move content from /wp/ to htdocs


#5

The best thing to do is to check the installation settings BEFORE installing, so you don’t end up installing a website to a subdirectory when you don’t want to.

You could either reinstall the website (and this time make sure the Directory setting is correct!) or update the URL (which is more complicated).


#6

Thanks guys i will try and write reply again :slight_smile:


#7